bmon: link dynamically unless explicitly requested otherwise
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 17 Jun 2011 07:10:29 +0000 (09:10 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 17 Jun 2011 07:10:29 +0000 (09:10 +0200)
Commit 009d8fceab4d (add --{enable,disable}-{shared,static} automatically)
caused us to pass --enable-static in the normal (non-static) case as well,
which bmon interpretes as a request to link the bmon program statically,
bloating the image.

Fix it by passing an extra --disable-static to bmon configure to nullify
this.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/bmon/bmon.mk

index e9b10b0147c03b5353e594c393f4390f5fd417ce..97d4b0231e5c866bbec3fef3d1890b88c6a611f9 100644 (file)
@@ -9,6 +9,11 @@ BMON_SOURCE = bmon-$(BMON_VERSION).tar.gz
 BMON_SITE = http://distfiles.gentoo.org/distfiles
 BMON_DEPENDENCIES = ncurses
 
+ifneq ($(BR2_PREFER_STATIC_LIB),y)
+# link dynamically unless explicitly requested otherwise
+BMON_CONF_OPT += --disable-static
+endif
+
 define BMON_UNINSTALL_TARGET_CMDS
        rm -f $(TARGET_DIR)/usr/bin/bmon
 endef