python-setuptools: bump to version 36.0.1
authorYegor Yefremov <yegorslists@googlemail.com>
Thu, 15 Jun 2017 08:03:19 +0000 (10:03 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 15 Jun 2017 20:29:22 +0000 (22:29 +0200)
Recent setuptools versions require bootstrap.py to be invoked
before the standard setup process. So create such pre configure
hooks for both host and target versions.

Change download location to GitHub because setuptools doesn't
provide *.tar.gz any longer.

Fix legal info. setuptools is now licensed under MIT licence.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python-setuptools/python-setuptools.hash
package/python-setuptools/python-setuptools.mk

index 88113fa1f9b815232eafc1d3849223697bc8eb62..de6ad56d44169b177287868ebe13339394a043ae 100644 (file)
@@ -1,4 +1,2 @@
-# From https://pypi.python.org/pypi/setuptools/18.7.1
-md5 a0984da9cd8d7b582e1fd7de67dfdbcc setuptools-18.7.1.tar.gz
 # Locally calculated
-sha256  aff36c95035e0b311eacb1434e3f7e85f5ccaad477773847e582978f8f45bd74  setuptools-18.7.1.tar.gz
+sha256  99339ac1b4c9bc0a74745d6ff196a207ddfb5f7ca75df76f3d8d081a7f70cecc  python-setuptools-v36.0.1.tar.gz
index 15edc6fd07b90c263ceae29a799e9b00f03d7861..1bdb78889f3be654de7898b84f87c0391ec17b79 100644 (file)
@@ -4,12 +4,20 @@
 #
 ################################################################################
 
-PYTHON_SETUPTOOLS_VERSION = 18.7.1
-PYTHON_SETUPTOOLS_SOURCE = setuptools-$(PYTHON_SETUPTOOLS_VERSION).tar.gz
-PYTHON_SETUPTOOLS_SITE = http://pypi.python.org/packages/source/s/setuptools
-PYTHON_SETUPTOOLS_LICENSE = Python Software Foundation or Zope Public License
-PYTHON_SETUPTOOLS_LICENSE_FILES = PKG-INFO
+PYTHON_SETUPTOOLS_VERSION = v36.0.1
+PYTHON_SETUPTOOLS_SITE = $(call github,pypa,setuptools,$(PYTHON_SETUPTOOLS_VERSION))
+PYTHON_SETUPTOOLS_LICENSE = MIT
+PYTHON_SETUPTOOLS_LICENSE_FILES = LICENSE
 PYTHON_SETUPTOOLS_SETUP_TYPE = setuptools
 
+# recent setuptools versions require bootstrap.py to be invoked
+# before the standard setup process.
+define PYTHON_SETUPTOOLS_RUN_BOOTSTRAP
+       cd  $(@D) && $(HOST_DIR)/usr/bin/python ./bootstrap.py
+endef
+
+PYTHON_SETUPTOOLS_PRE_CONFIGURE_HOOKS = PYTHON_SETUPTOOLS_RUN_BOOTSTRAP
+HOST_PYTHON_SETUPTOOLS_PRE_CONFIGURE_HOOKS = PYTHON_SETUPTOOLS_RUN_BOOTSTRAP
+
 $(eval $(python-package))
 $(eval $(host-python-package))