u-boot: get rid of version specific patch dirs
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 23 Mar 2009 13:30:30 +0000 (13:30 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 23 Mar 2009 13:30:30 +0000 (13:30 -0000)
All those dirs seem a bit excessive for a single patch

target/u-boot/1.2.0-atmel/.empty [deleted file]
target/u-boot/1.3.4/.empty [deleted file]
target/u-boot/2008.10/.empty [deleted file]
target/u-boot/2009.01/.empty [deleted file]
target/u-boot/2009.01/u-boot-2009.01-include_asm-avr32_io.h.patch.avr32 [deleted file]
target/u-boot/Makefile.in
target/u-boot/u-boot-2009.01-include_asm-avr32_io.h.patch.avr32 [new file with mode: 0644]

diff --git a/target/u-boot/1.2.0-atmel/.empty b/target/u-boot/1.2.0-atmel/.empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/target/u-boot/1.3.4/.empty b/target/u-boot/1.3.4/.empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/target/u-boot/2008.10/.empty b/target/u-boot/2008.10/.empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/target/u-boot/2009.01/.empty b/target/u-boot/2009.01/.empty
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/target/u-boot/2009.01/u-boot-2009.01-include_asm-avr32_io.h.patch.avr32 b/target/u-boot/2009.01/u-boot-2009.01-include_asm-avr32_io.h.patch.avr32
deleted file mode 100644 (file)
index 07cddb0..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -urN u-boot-2009.01-rc3/include/asm-avr32/io.h u-boot-avr32//include/asm-avr32/io.h
---- u-boot-2009.01-rc3/include/asm-avr32/io.h  2009-01-18 21:37:48.000000000 +0100
-+++ u-boot-avr32//include/asm-avr32/io.h       2009-01-22 07:14:38.000000000 +0100
-@@ -125,9 +125,4 @@
- }
--static inline phys_addr_t virt_to_phys(void * vaddr)
--{
--      return (phys_addr_t)(vaddr);
--}
--
- #endif /* __ASM_AVR32_IO_H */
index be889a07617d226fecb03474dfb2e9098e4c42f4..cd184045da5bdecd95fe24b71c6de6187c2ebaca 100644 (file)
@@ -81,7 +81,7 @@ $(U_BOOT_DIR)/.unpacked: $(DL_DIR)/$(U_BOOT_SOURCE)
        touch $@
 
 $(U_BOOT_DIR)/.patched: $(U_BOOT_DIR)/.unpacked
-       toolchain/patch-kernel.sh $(U_BOOT_DIR) target/u-boot/$(U_BOOT_VERSION) \
+       toolchain/patch-kernel.sh $(U_BOOT_DIR) target/u-boot \
                u-boot-$(U_BOOT_VERSION)-\*.patch \
                u-boot-$(U_BOOT_VERSION)-\*.patch.$(ARCH)
 ifneq ($(strip $(U_BOOT_ARCH_PATCH_DIR)),)
diff --git a/target/u-boot/u-boot-2009.01-include_asm-avr32_io.h.patch.avr32 b/target/u-boot/u-boot-2009.01-include_asm-avr32_io.h.patch.avr32
new file mode 100644 (file)
index 0000000..07cddb0
--- /dev/null
@@ -0,0 +1,13 @@
+diff -urN u-boot-2009.01-rc3/include/asm-avr32/io.h u-boot-avr32//include/asm-avr32/io.h
+--- u-boot-2009.01-rc3/include/asm-avr32/io.h  2009-01-18 21:37:48.000000000 +0100
++++ u-boot-avr32//include/asm-avr32/io.h       2009-01-22 07:14:38.000000000 +0100
+@@ -125,9 +125,4 @@
+ }
+-static inline phys_addr_t virt_to_phys(void * vaddr)
+-{
+-      return (phys_addr_t)(vaddr);
+-}
+-
+ #endif /* __ASM_AVR32_IO_H */