package/cannelloni: bump to version 1.0.0
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 14 Jun 2020 21:20:10 +0000 (23:20 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Jun 2020 20:58:32 +0000 (22:58 +0200)
- Drop patch (already in version)
- Add -std=c++11 to fix the build with gcc 4.8 as it has been removed by
  upstream since version 1.0.0 and
  https://github.com/mguentner/cannelloni/commit/2558902f0b2c2750ce99d05ac3cfe149c391482b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/cannelloni/0001-Add-missing-cstdio-include.patch [deleted file]
package/cannelloni/cannelloni.hash
package/cannelloni/cannelloni.mk

diff --git a/package/cannelloni/0001-Add-missing-cstdio-include.patch b/package/cannelloni/0001-Add-missing-cstdio-include.patch
deleted file mode 100644 (file)
index 1e4ad00..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From d41f5ec6bb66654558757c3ef9cd2a158ee06ccc Mon Sep 17 00:00:00 2001
-From: Yegor Yefremov <yegorslists@googlemail.com>
-Date: Wed, 15 Feb 2017 09:29:29 +0100
-Subject: [PATCH] Add missing <cstdio> include
-
-This header defines EOF macro. Some toolchains cannot
-find this macro, if <cstdio> is missing. So include it
-explicitly.
-
-Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
----
- sctpthread.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/sctpthread.cpp b/sctpthread.cpp
-index 6c83fed..d83b472 100644
---- a/sctpthread.cpp
-+++ b/sctpthread.cpp
-@@ -19,6 +19,7 @@
-  */
- #include <chrono>
-+#include <cstdio>
- #include <algorithm>
- #include <string.h>
--- 
-2.1.4
-
index 41cb72816da5330e36e681f75764e013811f6eb1..107415b0acbff4e90ec8f980230791a9ed76811c 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256  fe5abb1c9e523049c48dd906603bc762cc55ccd20c16dbec7dc64163b9eefccf  cannelloni-20160414.tar.gz
+sha256  de44b7e327fbf38883f46e51a5afd07de5144f2e44c5f42b7f2f0741165f0b13  cannelloni-1.0.0.tar.gz
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  gpl-2.0.txt
index cc99c54aa1bee950e3591a3675fb5693e03f3190..f97a091760a31967fb5d106aca52f877b70eb745 100644 (file)
@@ -4,10 +4,11 @@
 #
 ################################################################################
 
-CANNELLONI_VERSION = 20160414
-CANNELLONI_SITE = $(call github,mguentner,cannelloni,$(CANNELLONI_VERSION))
+CANNELLONI_VERSION = 1.0.0
+CANNELLONI_SITE = $(call github,mguentner,cannelloni,v$(CANNELLONI_VERSION))
 CANNELLONI_LICENSE = GPL-2.0
 CANNELLONI_LICENSE_FILES = gpl-2.0.txt
+CANNELLONI_CONF_OPTS = -DCMAKE_CXX_FLAGS="-std=c++11"
 
 ifeq ($(BR2_PACKAGE_LKSCTP_TOOLS),y)
 CANNELLONI_CONF_OPTS += -DSCTP_SUPPORT=ON