ifupdown-scripts: do not install .empty files
authorCam Hutchison <camh@xdna.net>
Sun, 15 Oct 2017 00:57:19 +0000 (11:57 +1100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 15 Oct 2017 13:47:43 +0000 (15:47 +0200)
ifupdown-scripts has some .empty files to maintain empty directories
in git. Previously this package used to be part of the skeleton which
used SYSTEM_RSYNC to copy the directories to the target. When it was
split into a separate package, cp -a was used to do the copy instead,
which copies the .empty files.

Change to SYSTEM_RSYNC which excludes .empty files.

Signed-off-by: Cam Hutchison <camh@xdna.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ifupdown-scripts/ifupdown-scripts.mk

index 317c8f49bf057b147bd22a599e02a708a632cf79..ebc89b38725804bff00eb97450a597756ae09e46 100644 (file)
@@ -31,7 +31,7 @@ endif
 
 define IFUPDOWN_SCRIPTS_INSTALL_TARGET_CMDS
        mkdir -p $(TARGET_DIR)/etc/network
-       cp -a $(IFUPDOWN_SCRIPTS_PKGDIR)/network/* $(TARGET_DIR)/etc/network
+       $(call SYSTEM_RSYNC,$(IFUPDOWN_SCRIPTS_PKGDIR)/network,$(TARGET_DIR)/etc/network)
        $(IFUPDOWN_SCRIPTS_LOCALHOST)
        $(IFUPDOWN_SCRIPTS_DHCP)
 endef