core/pkg-kconfig: do not always silence oldconfig
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 20 Jul 2015 20:27:13 +0000 (22:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 20 Jul 2015 20:39:28 +0000 (22:39 +0200)
When debugging packages that use the pkg-kconfig infrastructure, it
is sometime interesting to see the exact command line that is being
executed when running oldconfig.

But currently, those command lines are prefixed with '@' which makes
them silent, always.

Instead, use $(Q) so they are silent by default, and verbose with V=1.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-kconfig.mk

index f708875bca004cf5b0db766261a457d96af0ad06..3e17a7003eae6a1f86a88584899e3b60ea7f7911 100644 (file)
@@ -65,14 +65,14 @@ $$($(2)_KCONFIG_FILE) $$($(2)_KCONFIG_FRAGMENT_FILES): | $(1)-patch
 $$($(2)_DIR)/.config: $$($(2)_KCONFIG_FILE) $$($(2)_KCONFIG_FRAGMENT_FILES)
        support/kconfig/merge_config.sh -m -O $$(@D) \
                $$($(2)_KCONFIG_FILE) $$($(2)_KCONFIG_FRAGMENT_FILES)
-       @yes "" | $$($(2)_MAKE_ENV) $$(MAKE) -C $$($(2)_DIR) \
+       $$(Q)yes "" | $$($(2)_MAKE_ENV) $$(MAKE) -C $$($(2)_DIR) \
                $$($(2)_KCONFIG_OPTS) oldconfig
 
 # In order to get a usable, consistent configuration, some fixup may be needed.
 # The exact rules are specified by the package .mk file.
 define $(2)_FIXUP_DOT_CONFIG
        $$($(2)_KCONFIG_FIXUP_CMDS)
-       @yes "" | $$($(2)_MAKE_ENV) $$(MAKE) -C $$($(2)_DIR) \
+       $$(Q)yes "" | $$($(2)_MAKE_ENV) $$(MAKE) -C $$($(2)_DIR) \
                $$($(2)_KCONFIG_OPTS) oldconfig
        $$(Q)touch $$($(2)_DIR)/.stamp_kconfig_fixup_done
 endef