do not install build stuff into the target unless specifically asked to do so
authorEric Andersen <andersen@codepoet.org>
Mon, 15 Jan 2007 21:28:15 +0000 (21:28 -0000)
committerEric Andersen <andersen@codepoet.org>
Mon, 15 Jan 2007 21:28:15 +0000 (21:28 -0000)
package/gettext/gettext.mk

index 3da4cd9e130e94110e85a23bccc0a45db02755ae..7a7340c3b48e1dc10e1c24922da69907130dfccb 100644 (file)
@@ -137,12 +137,14 @@ gettext-target: $(GETTEXT_DIR)/$(GETTEXT_BINARY)
                $(TARGET_DIR)/usr/include/libintl.h
        -rmdir $(TARGET_DIR)/usr/include
 
-libintl: $(TARGET_DIR)/lib/libintl.so
-
 $(TARGET_DIR)/lib/libintl.so: $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY)
-       cp -a $(STAGING_DIR)/lib/libintl.so* $(TARGET_DIR)/lib
+       cp -a $(STAGING_DIR)/lib/libgettext*.so* $(TARGET_DIR)/lib/
+       cp -a $(STAGING_DIR)/lib/libintl*.so* $(TARGET_DIR)/lib/
+       rm -f $(TARGET_DIR)/lib/libgettext*.so*.la $(TARGET_DIR)/lib/libintl*.so*.la
        touch $@
 
+libintl: $(TARGET_DIR)/lib/libintl.so
+
 #############################################################
 #
 # Toplevel Makefile options
@@ -152,5 +154,5 @@ ifeq ($(strip $(BR2_PACKAGE_LIBINTL)),y)
 TARGETS+=libintl
 endif
 ifeq ($(strip $(BR2_PACKAGE_GETTEXT)),y)
-TARGETS+=gettext-target
+TARGETS+=gettext
 endif