package/riscv64-elf-toolchain: new package
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 4 May 2021 20:51:35 +0000 (22:51 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 7 May 2021 20:48:23 +0000 (22:48 +0200)
This commit adds a new package for a prebuilt bare-metal toolchain for
RISC-V 64-bit. Indeed, some bootloader/firmware for the BeagleV (and
potentially later for other platforms?) do not build with a
Linux-capable toolchain.

This uses a pre-built toolchain from SiFive, precompiled for x86-64,
so all packages using this toolchain must have the appropriate
BR2_HOSTARCH dependency.

This package is modeled after package/arm-gnu-a-toolchain/, which
package a pre-built ARM32 bare-metal toolchain.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
DEVELOPERS
package/riscv64-elf-toolchain/riscv64-elf-toolchain.mk [new file with mode: 0644]

index c5f9f36578439b829e052146304307b606d13d55..bcf42dc9cbbbbb68a5adae71a45a7f12a2c0bd1b 100644 (file)
@@ -2651,6 +2651,7 @@ F:        package/python3/
 F:     package/python-mad/
 F:     package/python-serial/
 F:     package/qextserialport/
+F:     package/riscv64-elf-toolchain/
 F:     package/rpcbind/
 F:     package/rt-tests/
 F:     package/rtc-tools/
diff --git a/package/riscv64-elf-toolchain/riscv64-elf-toolchain.mk b/package/riscv64-elf-toolchain/riscv64-elf-toolchain.mk
new file mode 100644 (file)
index 0000000..9b08ee0
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# riscv64-elf-toolchain
+#
+################################################################################
+
+RISCV64_ELF_TOOLCHAIN_VERSION = 2020.12.8
+RISCV64_ELF_TOOLCHAIN_SITE = https://static.dev.sifive.com/dev-tools/freedom-tools/v2020.12
+RISCV64_ELF_TOOLCHAIN_SOURCE = riscv64-unknown-elf-toolchain-10.2.0-$(RISCV64_ELF_TOOLCHAIN_VERSION)-x86_64-linux-centos6.tar.gz
+
+HOST_RISCV64_ELF_TOOLCHAIN_INSTALL_DIR = $(HOST_DIR)/opt/riscv64-elf
+
+define HOST_RISCV64_ELF_TOOLCHAIN_INSTALL_CMDS
+       rm -rf $(HOST_RISCV64_ELF_TOOLCHAIN_INSTALL_DIR)
+       mkdir -p $(HOST_RISCV64_ELF_TOOLCHAIN_INSTALL_DIR)
+       cp -rf $(@D)/* $(HOST_RISCV64_ELF_TOOLCHAIN_INSTALL_DIR)/
+
+       mkdir -p $(HOST_DIR)/bin
+       cd $(HOST_DIR)/bin && \
+       for i in ../opt/riscv64-elf/bin/*; do \
+               ln -sf $$i; \
+       done
+endef
+
+$(eval $(host-generic-package))