arch: drop now useless support for FDPIC
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 21 May 2018 16:17:06 +0000 (18:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 1 Jul 2018 13:17:27 +0000 (15:17 +0200)
Now that we dropped support for blackfin, we no longer have any
architecture that supports FDPIC, so BR2_ARCH_HAS_FDPIC_SUPPORT
is never selected, so we can't select BR2_BINFMT_FDPIC.

Drop all of that now.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
arch/Config.in
package/uclibc/uclibc.mk

index a16012bdfd3b54b24ad46df7b34c145a02e1f10f..7d1aeb2174fffcc378ae1cdf8ae9a1a3124d2145 100644 (file)
@@ -15,9 +15,6 @@ config BR2_ARCH_HAS_MMU_MANDATORY
 config BR2_ARCH_HAS_MMU_OPTIONAL
        bool
 
-config BR2_ARCH_HAS_FDPIC_SUPPORT
-       bool
-
 choice
        prompt "Target Architecture"
        default BR2_i386
@@ -344,7 +341,6 @@ config BR2_READELF_ARCH_NAME
 choice
        prompt "Target Binary Format"
        default BR2_BINFMT_ELF if BR2_USE_MMU
-       default BR2_BINFMT_FDPIC if BR2_ARCH_HAS_FDPIC_SUPPORT
        default BR2_BINFMT_FLAT
 
 config BR2_BINFMT_ELF
@@ -356,16 +352,6 @@ config BR2_BINFMT_ELF
          and executables used across different architectures and
          operating systems.
 
-config BR2_BINFMT_FDPIC
-       bool "FDPIC"
-       depends on BR2_ARCH_HAS_FDPIC_SUPPORT
-       select BR2_BINFMT_SUPPORTS_SHARED
-       help
-         ELF FDPIC binaries are based on ELF, but allow the individual
-         load segments of a binary to be located in memory
-         independently of each other. This makes this format ideal for
-         use in environments where no MMU is available.
-
 config BR2_BINFMT_FLAT
        bool "FLAT"
        depends on !BR2_USE_MMU
index bb44da28b4a243886d95a65fc0ef1c5f9c65e2f9..63d36943edb8212b2e6e0e8b63d78c454e4a325b 100644 (file)
@@ -52,14 +52,6 @@ UCLIBC_LOCALES = \
 endif
 
 # noMMU binary formats
-ifeq ($(BR2_BINFMT_FDPIC),y)
-define UCLIBC_BINFMT_CONFIG
-       $(call KCONFIG_DISABLE_OPT,UCLIBC_FORMAT_FLAT,$(@D)/.config)
-       $(call KCONFIG_DISABLE_OPT,UCLIBC_FORMAT_FLAT_SEP_DATA,$(@D)/.config)
-       $(call KCONFIG_DISABLE_OPT,UCLIBC_FORMAT_SHARED_FLAT,$(@D)/.config)
-       $(call KCONFIG_ENABLE_OPT,UCLIBC_FORMAT_FDPIC_ELF,$(@D)/.config)
-endef
-endif
 ifeq ($(BR2_BINFMT_FLAT_ONE),y)
 define UCLIBC_BINFMT_CONFIG
        $(call KCONFIG_ENABLE_OPT,UCLIBC_FORMAT_FLAT,$(@D)/.config)