openvpn: add option for --enable-password-save
authorAndreas Wetzel <andreas.wetzel@nanotronic.ch>
Wed, 23 Sep 2015 09:39:48 +0000 (11:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Sep 2015 11:04:33 +0000 (13:04 +0200)
Added configuration option BR2_PACKAGE_OPENVPN_PWSAVE that
adds --enable-password-save to OPENVPN_CONF_OPTS if selected.

[Thomas: rewrap Config.in help text, as suggested by Vicente.]

Signed-off-by: Andreas Wetzel <andreas.wetzel@nanotronic.ch>
Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openvpn/Config.in
package/openvpn/openvpn.mk

index 5edb479d9f7da62ce099e751e3d070440e048f61..2e3712554ed17766e936b3ab1e0bbea964028ac3 100644 (file)
@@ -27,6 +27,12 @@ config BR2_PACKAGE_OPENVPN_SMALL
          You loose eurephia, debugging info, help messages and more.
          It saves around 100 KiB in binary file size.
 
+config BR2_PACKAGE_OPENVPN_PWSAVE
+       bool "Allow passwords in files"
+       help
+         Allow --askpass and --auth-user-pass passwords to be read
+         from a file.
+
 choice
        prompt "Crypto backend"
        default BR2_PACKAGE_OPENVPN_CRYPTO_OPENSSL
index 1caa9a0336f4d8f31777d0789fac4410bfaafbc7..2973928a731367bc6a834611407f5bf6919e7e74 100644 (file)
@@ -41,6 +41,12 @@ else
 OPENVPN_CONF_OPTS += --disable-lzo
 endif
 
+ifeq ($(BR2_PACKAGE_OPENVPN_PWSAVE),y)
+OPENVPN_CONF_OPTS += --enable-password-save
+else
+OPENVPN_CONF_OPTS += --disable-password-save
+endif
+
 ifeq ($(BR2_PACKAGE_OPENVPN_CRYPTO_OPENSSL),y)
 OPENVPN_CONF_OPTS += --with-crypto-library=openssl
 OPENVPN_DEPENDENCIES += openssl