package/sqlite: Dynamically link libsqlite.so to bin/sqlite3
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 23 Jan 2016 10:23:43 +0000 (11:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 23 Jan 2016 11:02:43 +0000 (12:02 +0100)
Fixes https://bugs.busybox.net/show_bug.cgi?id=8621#c1
Lonnie Abelbeck wrote:
"recently sqlite changed it's default behavior wrt the sqlite CLI tool,
 previously it was dynamically linked with libsqlite3.so.0 by default,
 now it is statically linked by default.

The old behavior can be signaled with: --disable-static-shell"

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sqlite/sqlite.mk

index 27dad1225500ff7dc747057e8a6fc30e5350ab59..46acbf8aecbfbdde26fb52dac0bd7045e00cc453 100644 (file)
@@ -35,6 +35,8 @@ SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) $(SQLITE_CFLAGS)"
 
 ifeq ($(BR2_STATIC_LIBS),y)
 SQLITE_CONF_OPTS += --enable-dynamic-extensions=no
+else
+SQLITE_CONF_OPTS += --disable-static-shell
 endif
 
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)