package/gstreamer1/gst1-plugins-ugly: libdvdread can now be linked statically
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Jun 2016 16:20:29 +0000 (18:20 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 19 Jun 2016 21:09:04 +0000 (23:09 +0200)
After libdvdread bump to version 5.0.3 static linking works, tested
using this defconfig:
http://autobuild.buildroot.net/toolchains/configs/br-arm-full-static.config

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-ugly/Config.in
package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk

index 995835e41a07b6eb20ca0d1225356bba285e6618..f30163aa0ab6b926462dd9c6316ee59989311c7d 100644 (file)
@@ -40,14 +40,10 @@ comment "plugins with external dependencies (there may be more available)"
 
 config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_DVDREAD
        bool "dvdread"
-       depends on !BR2_STATIC_LIBS # libdvdread
        select BR2_PACKAGE_LIBDVDREAD
        help
          Access a DVD with dvdread
 
-comment "dvdread needs a toolchain w/ dynamic library"
-       depends on BR2_STATIC_LIBS
-
 config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_LAME
        bool "lame (*.mp3 audio encoder)"
        select BR2_PACKAGE_LAME
index d37908c34177eb7015dce5c90ec17ae02d9b8d1f..8864b04c717630130839f296f3969ca17919cf34 100644 (file)
@@ -59,6 +59,10 @@ GST1_PLUGINS_UGLY_CONF_OPTS += --disable-realmedia
 endif
 
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_DVDREAD),y)
+# configure does not use pkg-config to detect libdvdread
+ifeq ($(BR2_PACKAGE_LIBDVDCSS)$(BR2_STATIC_LIBS),yy)
+GST1_PLUGINS_UGLY_CONF_ENV += LIBS="-ldvdcss"
+endif
 GST1_PLUGINS_UGLY_CONF_OPTS += --enable-dvdread
 GST1_PLUGINS_UGLY_DEPENDENCIES += libdvdread
 GST1_PLUGINS_UGLY_HAS_GPL_LICENSE = y