hostapd: make ACS optional
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 3 Dec 2015 16:40:38 +0000 (13:40 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 3 Dec 2015 20:38:50 +0000 (21:38 +0100)
Make ACS (Automatic Channel Selection) support in hostapd optional.
There's a clash of standard vs. propietary solutions, hence when hostapd
has builtin ACS support (standard) and it's enabled (channel=0 in the
config) this will preclude the propietary driver from using ACS (it
won't work at all).

See:
http://e2e.ti.com/support/wireless_connectivity/f/307/p/465333/1669270

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/hostapd/Config.in
package/hostapd/hostapd.mk

index 656645bff15eb7d325469f1d8e6db9dd2763170e..62fbb66d639865d5d2280d467c9eed225ae78aab 100644 (file)
@@ -14,6 +14,16 @@ config BR2_PACKAGE_HOSTAPD
 
 if BR2_PACKAGE_HOSTAPD
 
+config BR2_PACKAGE_HOSTAPD_ACS
+       bool "Enable ACS"
+       default y
+       help
+         Enable support for standard ACS (Automatic Channel Selection).
+         Some propietary drivers use a custom algorithm which requires
+         channel to be set to '0' (which enables ACS in the config),
+         causing hostapd to use the standard one which doesn't work
+         for those cases.
+
 config BR2_PACKAGE_HOSTAPD_EAP
        bool "Enable EAP"
        depends on !BR2_STATIC_LIBS
index e22e53f81916b6ad48614b3006dff765c6d031bb..88867e6d8a7d04ca91573ef79eec8776d178d1a6 100644 (file)
@@ -15,7 +15,6 @@ HOSTAPD_LICENSE_FILES = README
 HOSTAPD_CONFIG_SET =
 
 HOSTAPD_CONFIG_ENABLE = \
-       CONFIG_ACS \
        CONFIG_FULL_DYNAMIC_VLAN \
        CONFIG_HS20 \
        CONFIG_IEEE80211AC \
@@ -45,6 +44,10 @@ HOSTAPD_CONFIG_DISABLE += CONFIG_EAP_PWD
 HOSTAPD_CONFIG_EDITS += 's/\#\(CONFIG_TLS=\).*/\1internal/'
 endif
 
+ifeq ($(BR2_PACKAGE_HOSTAPD_ACS),y)
+HOSTAPD_CONFIG_ENABLE += CONFIG_ACS
+endif
+
 ifeq ($(BR2_PACKAGE_HOSTAPD_EAP),y)
 HOSTAPD_CONFIG_ENABLE += \
        CONFIG_EAP \