kvm-unit-tests: only enable for ARM on Cortex-A{7,12,15,17}
authorArnout Vandecappelle <arnout@mind.be>
Sun, 20 Nov 2016 13:50:06 +0000 (14:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Nov 2016 14:48:10 +0000 (15:48 +0100)
The library uses the hypervisor instruction HVC, which is only
available on ARMv7-A with Hypervisor extensions. This is limited to
Cortex-A{7,12,15,17}.

In addition the build unconditionally passes -marm so it also needs
ARM instructions to be available, but that is already implied by the
CPU selection.

Implicitly fixes
http://autobuild.buildroot.net/results/53d109fd9055fd20387bb857aced5f89cf3086fd
though it is still not clear why ld doesn't accept the -Ttext=...
option there.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
[Thomas: A12 and A17 also have the virtualization extensions.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kvm-unit-tests/Config.in

index f704a8e0c3533bfd7e2342096101d50ded937e1c..72656462e16cf45e66512bd8b7c92bbb963d97e1 100644 (file)
@@ -4,7 +4,9 @@ config BR2_PACKAGE_KVM_UNIT_TESTS
        # on i386 and x86-64, __builtin_reachable is used, so we need
        # gcc 4.5 at least. on i386, we use the target gcc, while on
        # x86-64 we use the host gcc (see .mk file for details)
-       depends on BR2_arm || \
+       # On ARM, it uses virtualization extensions
+       depends on BR2_cortex_a7 || BR2_cortex_a12 || \
+               BR2_cortex_a15 || BR2_cortex_a17 || \
                (BR2_i386 && BR2_TOOLCHAIN_GCC_AT_LEAST_4_5) || \
                BR2_powerpc64 || \
                BR2_powerpc64le || \