pcre: enable unicode properties for host variant
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 22 Mar 2016 21:38:00 +0000 (18:38 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 22 Mar 2016 22:03:27 +0000 (23:03 +0100)
They're required for host-libglib2 and using system pcre is the
default/recommended with newer versions.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pcre/pcre.mk

index 06652c70e4d72b17d8bdc174ae055870970fa0e8..7fcc592a14ca56508c143d3de9f89930cfa14e97 100644 (file)
@@ -12,6 +12,9 @@ PCRE_LICENSE_FILES = LICENCE
 PCRE_INSTALL_STAGING = YES
 PCRE_CONFIG_SCRIPTS = pcre-config
 
+# They're required for host-libglib2
+HOST_PCRE_CONF_OPTS = --enable-unicode-properties
+
 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 # pcre will use the host g++ if a cross version isn't available
 PCRE_CONF_OPTS = --disable-cpp