package/kodi-vfs-rar: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 21 Sep 2019 19:28:04 +0000 (21:28 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 21 Sep 2019 20:59:07 +0000 (22:59 +0200)
Internal rar support in Kodi was moved to this addon with the Kodi
release 18.0-Leia, see upstream PR 11912.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Arnout: fix license, add license file hashes]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/kodi-vfs-rar/Config.in [new file with mode: 0644]
package/kodi-vfs-rar/kodi-vfs-rar.hash [new file with mode: 0644]
package/kodi-vfs-rar/kodi-vfs-rar.mk [new file with mode: 0644]
package/kodi/Config.in

diff --git a/package/kodi-vfs-rar/Config.in b/package/kodi-vfs-rar/Config.in
new file mode 100644 (file)
index 0000000..f855fb6
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_KODI_VFS_RAR
+       bool "kodi-vfs-rar"
+       select BR2_PACKAGE_LIBPLATFORM
+       help
+         RAR VFS addon for Kodi
+
+         https://github.com/xbmc/vfs.rar
diff --git a/package/kodi-vfs-rar/kodi-vfs-rar.hash b/package/kodi-vfs-rar/kodi-vfs-rar.hash
new file mode 100644 (file)
index 0000000..f0b5398
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally computed
+sha256 09a16bf0be13c7d9ed43c6608f662374cb3b8b35c05492ce1117f58270d8d005  kodi-vfs-rar-60f92ff28ee6c94211b628990696c60518bffcf6.tar.gz
+# License files
+sha256 e0c2f13c3a78c8d2b91cb846b8a13fb650fcc88c0630e38ce9c0b7c34631d1cc  lib/UnrarXLib/license.txt
+sha256 2ddada473db917f5d0ed191d8b571aa04af8926807f61398e602b971eaf5ccb7  src/RarManager.h
diff --git a/package/kodi-vfs-rar/kodi-vfs-rar.mk b/package/kodi-vfs-rar/kodi-vfs-rar.mk
new file mode 100644 (file)
index 0000000..b113fa5
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# kodi-vfs-rar
+#
+################################################################################
+
+KODI_VFS_RAR_VERSION = 60f92ff28ee6c94211b628990696c60518bffcf6
+KODI_VFS_RAR_SITE = $(call github,xbmc,vfs.rar,$(KODI_VFS_RAR_VERSION))
+KODI_VFS_RAR_LICENSE = unrar, GPL-2.0+
+KODI_VFS_RAR_LICENSE_FILES = lib/UnrarXLib/license.txt src/RarManager.h
+KODI_VFS_RAR_DEPENDENCIES = libplatform kodi
+
+$(eval $(cmake-package))
index 626038e8c8c6606b88b6c36c4d90ae4bdb65657f..f62c2f4c9de52c63d1f0fc611fa3777a2efaae60 100644 (file)
@@ -354,6 +354,10 @@ menu "Skins"
        source "package/kodi-skin-confluence/Config.in"
 endmenu
 
+menu "Virtual file systems"
+       source "package/kodi-vfs-rar/Config.in"
+endmenu
+
 menu "Visualisations"
        source "package/kodi-visualisation-fishbmc/Config.in"
        source "package/kodi-visualisation-goom/Config.in"