- if $(PKG)_SKIP_CONFIGURE is non-empty then ./configure is skipped
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 22 Aug 2007 16:56:36 +0000 (16:56 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 22 Aug 2007 16:56:36 +0000 (16:56 -0000)
package/Makefile.autotools.in

index 6d474402e9caf877dce549adde05fee1683b3134..7f2afffc75b0367318dae10f58494d26782c2329 100644 (file)
@@ -310,7 +310,8 @@ else
 $(1)-install-staging:
 endif
 
-$(1)-build:            $(1)-configure $$($(2)_TARGET_BUILD) \
+$(1)-build:            $(if $$($(2)_SKIP_CONFIGURE),$(1)-patch,$(1)-configure)\
+                       $$($(2)_TARGET_BUILD) \
                        $$($(2)_HOOK_POST_BUILD)
 
 $(1)-configure:                $(1)-autoreconf $$($(2)_TARGET_CONFIGURE)