Create some symlinks for {*-}cc since gcc 3.3.6 (at least) doesn't seem to install...
authorManuel Novoa III <mjn3@codepoet.org>
Wed, 3 Aug 2005 01:25:12 +0000 (01:25 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Wed, 3 Aug 2005 01:25:12 +0000 (01:25 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk

index 6027cf8b7d0332783d30da9ba2219e0f80b71a18..ff08458c5bfff5ade1b44dc20bb8a734ed5f30c9 100644 (file)
@@ -180,6 +180,14 @@ $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
 ifeq ($(GCC_STRIP_HOST_BINARIES),true)
        -strip --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*
 endif
+       # Make sure we have 'cc'.
+       if [ ! -e $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-cc ] ; then \
+               ln -snf $(REAL_GNU_TARGET_NAME)-gcc \
+                       $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-cc ; \
+       fi;
+       if [ ! -e $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/cc ] ; then \
+               ln -snf gcc $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/cc ; \
+       fi;
        # Set up the symlinks to enable lying about target name.
        set -e; \
        (cd $(STAGING_DIR); \
@@ -326,6 +334,10 @@ endif
                cp -f $(STAGING_DIR)/$(GCC_LIB_SUBDIR)/include/syslimits.h \
                        $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/include/ ; \
        fi
+       # Make sure we have 'cc'.
+       if [ ! -e $(TARGET_DIR)/usr/bin/cc ] ; then \
+               ln -snf gcc $(TARGET_DIR)/usr/bin/cc ; \
+       fi;
        # These are in /lib, so...
        #rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
        #touch -c $(TARGET_DIR)/usr/bin/gcc