sound-theme-borealis: new package
authorSimon Dawson <spdawson@gmail.com>
Fri, 20 Jul 2012 09:20:03 +0000 (10:20 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Jul 2012 19:08:53 +0000 (21:08 +0200)
[thomas.petazzoni@free-electrons.com:
  slightly adjust the installation process to just do a loop of calls
  to $(INSTALL).]

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/sound-theme-borealis/Config.in [new file with mode: 0644]
package/sound-theme-borealis/sound-theme-borealis.mk [new file with mode: 0644]

index 46747d96b31bf83bd99d6adae7498a59054d6461..ab5781c3e92db23ab9a14f476313ac81268b725f 100644 (file)
@@ -499,6 +499,7 @@ source "package/collectd/Config.in"
 source "package/empty/Config.in"
 source "package/mobile-broadband-provider-info/Config.in"
 source "package/shared-mime-info/Config.in"
+source "package/sound-theme-borealis/Config.in"
 source "package/sound-theme-freedesktop/Config.in"
 endmenu
 
diff --git a/package/sound-theme-borealis/Config.in b/package/sound-theme-borealis/Config.in
new file mode 100644 (file)
index 0000000..fcc109f
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_SOUND_THEME_BOREALIS
+       bool "sound-theme-borealis"
+       help
+         Borealis sound theme.
+
+         http://kde-look.org/content/show.php?content=12584
diff --git a/package/sound-theme-borealis/sound-theme-borealis.mk b/package/sound-theme-borealis/sound-theme-borealis.mk
new file mode 100644 (file)
index 0000000..afca72a
--- /dev/null
@@ -0,0 +1,21 @@
+#############################################################
+#
+# sound-theme-borealis
+#
+#############################################################
+SOUND_THEME_BOREALIS_VERSION = 0.9a
+SOUND_THEME_BOREALIS_SITE = http://ico.bukvic.net/Linux/Borealis_soundtheme
+SOUND_THEME_BOREALIS_SOURCE = \
+       Borealis_sound_theme_ogg-$(SOUND_THEME_BOREALIS_VERSION).tar.bz2
+
+define SOUND_THEME_BOREALIS_INSTALL_TARGET_CMDS
+       for f in $(@D)/*.ogg ; do \
+               $(INSTALL) -D -m 0644 $$f $(TARGET_DIR)/usr/share/sounds/borealis/stereo/`basename $$f` ; \
+       done
+endef
+
+define SOUND_THEME_BOREALIS_UNINSTALL_TARGET_CMDS
+       $(RM) -r $(TARGET_DIR)/usr/share/sounds/borealis
+endef
+
+$(eval $(generic-package))