boost: Pass staging dir to --with-icu option.
authorIgnacy Gawedzki <i@lri.fr>
Thu, 7 Feb 2013 03:48:35 +0000 (03:48 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 9 Feb 2013 09:55:59 +0000 (10:55 +0100)
When using the --with-icu option without specifying the directory, boost's
bootstrap.sh script will look at "common" locations (lines 289-294):

    COMMON_ICU_PATHS="/usr /usr/local /sw"
    for p in $COMMON_ICU_PATHS; do
      if test -r $p/include/unicode/utypes.h; then
        ICU_ROOT=$p
      fi
    done

With buildroot it may surely become problematic at some point.

Signed-off-by: Ignacy Gawędzki <i@lri.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/boost/boost.mk

index 5e1bb4e24862e2e2ab879017d5ff38b153f649b4..a2028484b4de6378ccb2f7d4fe4636729ea903f5 100644 (file)
@@ -39,7 +39,7 @@ BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_TIMER),,timer)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_WAVE),,wave)
 
 ifeq ($(BR2_PACKAGE_ICU),y)
-BOOST_FLAGS += --with-icu
+BOOST_FLAGS += --with-icu=$(STAGING_DIR)/usr
 BOOST_DEPENDENCIES += icu
 else
 BOOST_FLAGS += --without-icu