systemd: add option to enable compatibility libs
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Mon, 14 Apr 2014 09:25:36 +0000 (11:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 16 Apr 2014 17:55:23 +0000 (19:55 +0200)
Since systemd 209, some libraries have been merged into libsystemd.so:

 - libsystemd-daemon.so
 - libsystemd-id128.so
 - libsystemd-journal.so
 - libsystemd-login.so

A new configuration menu entry has been added to enable the installation
of compatibility pkg-config files, so that programs that depend on them
can still be built.

[Thomas: as suggested by Yann during the review, add an else clause
with --disable-compat-libs.]

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/Config.in
package/systemd/systemd.mk

index 095fee0336ea27791831d947d27124224e52e04f..f10637af707c35499590708199cd5c48a39f8b4e 100644 (file)
@@ -92,4 +92,17 @@ config BR2_PACKAGE_SYSTEMD_NETWORKD
 
          http://www.freedesktop.org/software/systemd/man/systemd-networkd.html
 
+config BR2_PACKAGE_SYSTEMD_COMPAT
+       bool "enable compatibility libraries"
+       help
+         Since systemd 209, the following libraries have been merged into
+         libsystemd.so:
+
+         - libsystemd-daemon
+         - libsystemd-id128
+         - libsystemd-journal
+         - libsystemd-login
+
+         This option enables the installation of compatibility *.pc files.
+
 endif
index ecedfced9793fc4e69bc49e63f8942afdb7029fe..f7661abb8c10a665e3ec79c7f23717e292ba19d7 100644 (file)
@@ -46,6 +46,12 @@ SYSTEMD_CONF_OPT += \
        --disable-dbus \
        --without-python
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_COMPAT),y)
+SYSTEMD_CONF_OPT += --enable-compat-libs
+else
+SYSTEMD_CONF_OPT += --disable-compat-libs
+endif
+
 ifeq ($(BR2_PACKAGE_ACL),y)
 SYSTEMD_CONF_OPT += --enable-acl
 SYSTEMD_DEPENDENCIES += acl