package: allow to override the make install target for host packages
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Jun 2013 19:28:53 +0000 (21:28 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 3 Jul 2013 05:35:52 +0000 (07:35 +0200)
In order to convert gcc to the package infrastructure, we need a way
of overriding the name of the make target used for the installation of
host packages, just like we have for target packages.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pkg-autotools.mk

index d8d7e6d47026b34dd00a8176615c60f009df2717..09deef2f36998405b99ca66250d5ed75abd6b844 100644 (file)
@@ -76,6 +76,7 @@ $(2)_MAKE_ENV                 ?=
 $(2)_MAKE_OPT                  ?=
 $(2)_AUTORECONF                        ?= NO
 $(2)_AUTORECONF_OPT            ?=
+$(2)_INSTALL_OPT                ?= install
 $(2)_INSTALL_STAGING_OPT       ?= DESTDIR=$$(STAGING_DIR) install
 $(2)_INSTALL_TARGET_OPT                ?= DESTDIR=$$(TARGET_DIR)  install
 $(2)_CLEAN_OPT                 ?= clean
@@ -232,7 +233,7 @@ endif
 #
 ifndef $(2)_INSTALL_CMDS
 define $(2)_INSTALL_CMDS
-       $$(HOST_MAKE_ENV) $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) -C $$($$(PKG)_SRCDIR) install
+       $$(HOST_MAKE_ENV) $$($$(PKG)_MAKE_ENV) $$($$(PKG)_MAKE) $$($$(PKG)_INSTALL_OPT) -C $$($$(PKG)_SRCDIR)
 endef
 endif