package/libiscsi: new package
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 13 Dec 2012 11:47:02 +0000 (11:47 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 14 Dec 2012 12:48:10 +0000 (13:48 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libiscsi/Config.in [new file with mode: 0644]
package/libiscsi/libiscsi.mk [new file with mode: 0644]

index cad1221c56284107743e662826877bd188f9b38e..dbb6704ede8e8842535b5c1ca0919ff27fc60e37 100644 (file)
@@ -466,6 +466,7 @@ source "package/libesmtp/Config.in"
 source "package/libeXosip2/Config.in"
 source "package/libfcgi/Config.in"
 source "package/libidn/Config.in"
+source "package/libiscsi/Config.in"
 source "package/liboauth/Config.in"
 source "package/libmicrohttpd/Config.in"
 source "package/neon/Config.in"
diff --git a/package/libiscsi/Config.in b/package/libiscsi/Config.in
new file mode 100644 (file)
index 0000000..f3fc29e
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_LIBISCSI
+       bool "libiscsi"
+       select BR2_PACKAGE_POPT
+       help
+         Libiscsi is a client-side library to implement the iSCSI protocol
+         that can be used to access resource of an iSCSI Target.
+         
+         The library is fully async with regards to iscsi commands and scsi
+         tasks, but a sync layer is also provided for ease of use for simpler
+         applications.
+         
+         https://github.com/sahlberg/libiscsi  (no proper homepage)
diff --git a/package/libiscsi/libiscsi.mk b/package/libiscsi/libiscsi.mk
new file mode 100644 (file)
index 0000000..bfebd7e
--- /dev/null
@@ -0,0 +1,15 @@
+#############################################################
+#
+# libiscsi
+#
+#############################################################
+
+LIBISCSI_VERSION         = 1.6.0
+LIBISCSI_SOURCE          = libiscsi-$(LIBISCSI_VERSION).tar.gz
+LIBISCSI_SITE            = https://github.com/downloads/sahlberg/libiscsi
+LIBISCSI_LICENSE         = GPLv2+ LGPLv2.1+
+LIBISCSI_LICENSE_FILES   = COPYING LICENCE-GPL-2.txt LICENCE-LGPL-2.1.txt
+LIBISCSI_INSTALL_STAGING = YES
+LIBISCSI_DEPENDENCIES    = popt
+
+$(eval $(autotools-package))