openssl: fix compiling OpenSSL for i386 architecture
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Tue, 7 Oct 2008 07:11:15 +0000 (07:11 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Tue, 7 Oct 2008 07:11:15 +0000 (07:11 -0000)
This patch will use linux-generic32 for all i386 target architectures, which
fixes bug #5274.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/openssl/openssl.mk

index c1959d018c2989e5438583a450f8bb60a6426ce8..b8c488f5f7618020c7de5c93558bc17521c5f5c3 100644 (file)
@@ -8,12 +8,7 @@ OPENSSL_SITE:=http://www.openssl.org/source
 
 OPENSSL_TARGET_ARCH:=
 ifeq ($(BR2_i386),y)
-ifneq ($(ARCH),i386)
-OPENSSL_TARGET_ARCH:=i386-$(ARCH)
-endif
-ifeq ($(ARCH),i686)
-OPENSSL_TARGET_ARCH:=i386-i686/cmov
-endif
+OPENSSL_TARGET_ARCH:=generic32
 endif
 ifeq ($(OPENSSL_TARGET_ARCH),)
 OPENSSL_TARGET_ARCH:=$(ARCH)