let people control location of download dir
authorMike Frysinger <vapier@gentoo.org>
Sat, 1 Oct 2005 00:35:24 +0000 (00:35 -0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 1 Oct 2005 00:35:24 +0000 (00:35 -0000)
Config.in
package/Makefile.in

index 30da7b65488260915849ec12bdfd23b98001cd1a..8714bc633c8d4ece7e3f5eb607cfd5532a9bd883 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -125,6 +125,12 @@ config BR2_TAR_VERBOSITY
        bool "Tar verbose"
        default n
 
+config BR2_DL_DIR
+       string "Download dir"
+       default "$(BASE_DIR)/dl"
+       help
+         Directory to store all the source files that we need to fetch.
+
 config BR2_SOURCEFORGE_MIRROR
        string "Sourceforge mirror site"
        default "easynews"
index 297ecffd59594e1f993d849e19f315fa7994b5f6..662ecacef2fa67299a14b71fb6b9173400c06da6 100644 (file)
@@ -11,10 +11,14 @@ SVN:=$(strip $(subst ",, $(BR2_SVN)))
 
 
 
+
 ifneq ($(BR2_LARGEFILE),y)
 DISABLE_LARGEFILE= --disable-largefile
 endif
 TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
+HOSTCC:=gcc
+
+BASE_DIR:=${shell pwd}
 
 TOPDIR_PREFIX:=$(strip $(subst ",, $(BR2_TOPDIR_PREFIX)))_
 TOPDIR_SUFFIX:=_$(strip $(subst ",, $(BR2_TOPDIR_SUFFIX)))
@@ -25,9 +29,10 @@ ifeq ($(TOPDIR_SUFFIX),_)
 TOPDIR_SUFFIX:=
 endif
 
-HOSTCC:=gcc
-BASE_DIR:=${shell pwd}
+DL_DIR=$(strip $(subst ",, $(BR2_DL_DIR)))
+ifeq ($(DL_DIR),)
 DL_DIR:=$(BASE_DIR)/dl
+endif
 #PATCH_DIR=$(BASE_DIR)/sources/patches
 BUILD_DIR:=$(BASE_DIR)/$(TOPDIR_PREFIX)build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)
 TARGET_DIR:=$(BUILD_DIR)/root