package/mesa3d: Enable support for Radeon r600 gallium driver
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 17 Jan 2015 17:03:55 +0000 (18:03 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 2 Feb 2015 20:43:13 +0000 (21:43 +0100)
--
v2: - rebased patch from micro1183: http://patchwork.ozlabs.org/patch/398858/
    - removed support for r300 & radeonsi because they need llvm support
      which is not provided by buildroot

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/Config.in
package/mesa3d/mesa3d.mk

index d8ee8c2e151a6fc0a72b7002d8ef623223b13578..c407ece5416f9e1ee392607fbe7a6a68fe9a73ec 100644 (file)
@@ -50,6 +50,15 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU
        help
          Supports all Nvidia GPUs.
 
+config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600
+       bool "Gallium Radeon R600 driver"
+       depends on BR2_i386 || BR2_x86_64
+       select BR2_PACKAGE_MESA3D_GALLIUM_DRIVER
+       select BR2_PACKAGE_LIBDRM_RADEON
+       select BR2_PACKAGE_MESA3D_NEEDS_XA
+       help
+         Driver for ATI/AMD Radeon R600/R700/HD5000/HD6000 GPUs.
+
 config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SVGA
        bool "Gallium vmware svga driver"
        depends on BR2_i386 || BR2_x86_64
index de647a6e5d00eef797d4fce3d1287b635a78bb60..8a84de37232b1cd4418f13584a8c12b70b99ac9a 100644 (file)
@@ -56,6 +56,7 @@ endif
 
 #Gallium Drivers
 MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU)  += nouveau
+MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600)     += r600
 MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SVGA)     += svga
 MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SWRAST)   += swrast
 # DRI Drivers