* Added neon
authorNigel Kukard <nkukard@lbsd.net>
Sat, 12 Apr 2008 09:56:15 +0000 (09:56 -0000)
committerNigel Kukard <nkukard@lbsd.net>
Sat, 12 Apr 2008 09:56:15 +0000 (09:56 -0000)
package/Config.in
package/neon/Config.in [new file with mode: 0644]
package/neon/neon.mk [new file with mode: 0644]

index f29de84f8c0dc5afd3ccc6e42e3b3fd0716ecffc..c1a89a6c0eec62d128dc962cd20fc544e2f9f815 100644 (file)
@@ -172,6 +172,7 @@ source "package/mrouted/Config.in"
 source "package/mutt/Config.in"
 source "package/nbd/Config.in"
 source "package/ncftp/Config.in"
+source "package/neon/Config.in"
 if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
 source "package/netcat/Config.in"
 endif
diff --git a/package/neon/Config.in b/package/neon/Config.in
new file mode 100644 (file)
index 0000000..8ac9d08
--- /dev/null
@@ -0,0 +1,38 @@
+config BR2_PACKAGE_NEON
+       bool "libneon"
+       default n
+       help
+         HTTP and WebDAV client library, with a C interface.
+
+         http://www.webdav.org/neon/
+
+choice
+       prompt "XML Support"
+       default BR2_PACKAGE_NEON_NOXML
+       depends BR2_PACKAGE_NEON
+       help
+         Select which XML library to use...
+         expat      use exapt
+         libxml2    use libxml2
+         none       do not build with XML support
+
+config BR2_PACKAGE_NEON_EXPAT
+       bool "expat"
+       depends BR2_PACKAGE_EXPAT
+       help
+         expat      use exapt, a library for parsing XML.
+
+config BR2_PACKAGE_NEON_LIBXML2
+       bool "libxml2"
+       depends BR2_PACKAGE_LIBXML2
+       help
+         libxml2    use libxml2, a library to read, modify and 
+                    write XML and HTML files.
+
+config BR2_PACKAGE_NEON_NOXML
+       bool "none"
+       help
+         none       don't use XML, if this is the only option
+                    and you want XML support, you must choose
+                    XML handling below.
+endchoice
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
new file mode 100644 (file)
index 0000000..36bfb3b
--- /dev/null
@@ -0,0 +1,25 @@
+#############################################################
+#
+# neon
+#
+#############################################################
+NEON_VERSION = 0.28.2
+NEON_SITE = http://www.webdav.org/neon/
+NEON_INSTALL_STAGING = YES
+
+NEON_CONF_OPT+=--enable-shared --without-gssapi --disable-rpath
+
+NEON_INSTALL_TARGET_OPT=DESTDIR=$(TARGET_DIR) install
+
+ifeq ($(strip $(BR2_PACKAGE_NEON_LIBXML2)),y)
+NEON_CONF_OPT+=--with-libxml2=yes
+NEON_CONF_OPT+=--with-expat=no
+NEON_DEPENDENCIES+=libxml2
+endif
+ifeq ($(strip $(BR2_PACKAGE_NEON_EXPAT)),y)
+NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
+NEON_CONF_OPT+=--with-libxml2=no
+NEON_DEPENDENCIES+=expat
+endif
+
+$(eval $(call AUTOTARGETS,package,neon))