package/meda3d: add xlib_libXvMC optional dependency
authorRomain Naour <romain.naour@gmail.com>
Sun, 26 Mar 2017 16:28:51 +0000 (18:28 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Apr 2017 13:56:58 +0000 (15:56 +0200)
If xlib_libXvMC package is build before mesa3d, it will be detected and
enabled by the configure script.

Handle xlib_libXvMC in mesa3d for consistency.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/mesa3d.mk

index 4b95e9b1668a7400e7dca7cb4e04e4a480843782..6fa1599dbf7834367ebf267209dc9cfaa90d0af1 100644 (file)
@@ -176,6 +176,13 @@ else
 MESA3D_CONF_OPTS += --disable-texture-float
 endif
 
+ifeq ($(BR2_PACKAGE_XLIB_LIBXVMC),y)
+MESA3D_DEPENDENCIES += xlib_libXvMC
+MESA3D_CONF_OPTS += --enable-xvmc
+else
+MESA3D_CONF_OPTS += --disable-xvmc
+endif
+
 ifeq ($(BR2_PACKAGE_LIBVDPAU),y)
 MESA3D_DEPENDENCIES += libvdpau
 MESA3D_CONF_OPTS += --enable-vdpau