mkpasswd: change version from 'undefined' to 'buildroot-$(BR2_VERSION)'
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Wed, 11 Jun 2014 19:12:29 +0000 (21:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Jun 2014 17:10:25 +0000 (19:10 +0200)
The sources of the mkpasswd package are shipped with Buildroot, rather than
downloaded from an external location. As a result, no explicit version is
defined, causing build messages and build directory to show 'undefined' as
version.

This patch sets the version for mkpasswd to 'buildroot-$(BR2_VERSION), which
would for example expand to 'buildroot-2014.05'.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mkpasswd/mkpasswd.mk

index dc6de19bc207521cfb8b45e16f51d8716f729e0a..0447ecc9a059c92265ee14c8c54e2ce604dc37e2 100644 (file)
@@ -10,6 +10,8 @@
 HOST_MKPASSWD_SOURCE =
 HOST_MKPASSWD_LICENSE = GPLv2+
 
+HOST_MKPASSWD_VERSION = buildroot-$(BR2_VERSION)
+
 define HOST_MKPASSWD_BUILD_CMDS
        $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) \
                package/mkpasswd/mkpasswd.c package/mkpasswd/utils.c \