pkg-autotools: re-order cleaning up the host dependencies
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 12 Nov 2014 00:25:48 +0000 (01:25 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Nov 2014 19:34:31 +0000 (20:34 +0100)
Move the host dependencies cleanup out from in-between all the hooks, so
it is easier to see how the hooks all work together.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-autotools.mk

index 60f6997ea0434b87a7b4eba065da372cd9b52117..6e198edf2a7bc069ca0211fb084555114e0eed27 100644 (file)
@@ -169,6 +169,14 @@ $(2)_INSTALL_OPTS                ?= install
 $(2)_INSTALL_STAGING_OPTS      ?= DESTDIR=$$(STAGING_DIR) install
 $(2)_INSTALL_TARGET_OPTS               ?= DESTDIR=$$(TARGET_DIR)  install
 
+# This must be repeated from inner-generic-package, otherwise we get an empty
+# _DEPENDENCIES if _AUTORECONF is YES.  Also filter the result of _AUTORECONF
+# and _GETTEXTIZE away from the non-host rule
+ifeq ($(4),host)
+$(2)_DEPENDENCIES ?= $$(filter-out host-automake host-autoconf host-libtool \
+                               host-gettext host-toolchain $(1),\
+    $$(patsubst host-host-%,host-%,$$(addprefix host-,$$($(3)_DEPENDENCIES))))
+endif
 
 #
 # Configure step. Only define it if not already defined by the package
@@ -248,15 +256,6 @@ ifneq ($$($(2)_LIBTOOL_PATCH),NO)
 $(2)_POST_PATCH_HOOKS += LIBTOOL_PATCH_HOOK
 endif
 
-# This must be repeated from inner-generic-package, otherwise we get an empty
-# _DEPENDENCIES if _AUTORECONF is YES.  Also filter the result of _AUTORECONF
-# and _GETTEXTIZE away from the non-host rule
-ifeq ($(4),host)
-$(2)_DEPENDENCIES ?= $$(filter-out host-automake host-autoconf host-libtool \
-                               host-gettext host-toolchain $(1),\
-    $$(patsubst host-host-%,host-%,$$(addprefix host-,$$($(3)_DEPENDENCIES))))
-endif
-
 ifeq ($$($(2)_AUTORECONF),YES)
 # This has to come before autoreconf
 ifeq ($$($(2)_GETTEXTIZE),YES)