- test if dir exists before trying to rmdir it.
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 30 Jul 2007 12:37:16 +0000 (12:37 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 30 Jul 2007 12:37:16 +0000 (12:37 -0000)
  Fixes failure due to non-existing usr/share dir on the target.

target/ext2/ext2root.mk

index 08a407eab54b12ac90c2a043b6fb1123d93ba48c..4ebb9814291ab28fe2814e36f55d0d5563906176 100644 (file)
@@ -91,7 +91,8 @@ $(EXT2_BASE): host-fakeroot makedevs genext2fs
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/share/man
        @rm -rf $(TARGET_DIR)/usr/info
-       @rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share
+       @test -d $(TARGET_DIR)/usr/share && \
+               rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share
        -/sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null
        # Use fakeroot to pretend all target binaries are owned by root
        rm -f $(STAGING_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))