Revert "package/assimp: fix musl zlib/zip related compile failure"
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 28 Jan 2021 20:04:33 +0000 (21:04 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 20 May 2021 19:45:23 +0000 (21:45 +0200)
This reverts commit b529a582ba4d7671597e95d7ab54ee652cbbc261 as it
raises a build failure with hiawatha because assimp installs its own
zlib library in staging directory.

Fixes:
 - http://autobuild.buildroot.org/results/9cac31962d48245a5579da692dbc9488292a397e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/assimp/0002-contrib-zip-fix-ssize_t-typedef-mismatch-for-musl-co.patch [deleted file]
package/assimp/Config.in
package/assimp/assimp.mk

diff --git a/package/assimp/0002-contrib-zip-fix-ssize_t-typedef-mismatch-for-musl-co.patch b/package/assimp/0002-contrib-zip-fix-ssize_t-typedef-mismatch-for-musl-co.patch
deleted file mode 100644 (file)
index a9a30c4..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-From 3fef857a570d1ef2c96401358fe8e239625b48c9 Mon Sep 17 00:00:00 2001
-From: Peter Seiderer <ps.report@gmx.net>
-Date: Fri, 10 Apr 2020 18:11:50 +0200
-Subject: [PATCH] contrib/zip: fix ssize_t typedef mismatch for musl compile
-
-Musl uses defines __DEFINED_ssize_t to indicate ssize_t
-availability. So backport this part of upstream commit [1]
-to fixl musl compile.
-
-https://github.com/assimp/assimp/commit/f78446b14aff46db2ef27d062a275b6a01fd68b1
-
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- contrib/zip/src/zip.h | 13 +++++++++++--
- 1 file changed, 11 insertions(+), 2 deletions(-)
-
-diff --git a/contrib/zip/src/zip.h b/contrib/zip/src/zip.h
-index 5f39df50..4672eb3e 100644
---- a/contrib/zip/src/zip.h
-+++ b/contrib/zip/src/zip.h
-@@ -20,8 +20,9 @@ extern "C" {
- #endif
- #if !defined(_SSIZE_T_DEFINED) && !defined(_SSIZE_T_DEFINED_) &&               \
--    !defined(_SSIZE_T) && !defined(_SSIZE_T_) && !defined(__ssize_t_defined)
--#define _SSIZE_T
-+    !defined(__DEFINED_ssize_t) && !defined(__ssize_t_defined) &&              \
-+    !defined(_SSIZE_T) && !defined(_SSIZE_T_)
-+
- // 64-bit Windows is the only mainstream platform
- // where sizeof(long) != sizeof(void*)
- #ifdef _WIN64
-@@ -29,6 +30,14 @@ typedef long long  ssize_t;  /* byte count or error */
- #else
- typedef long  ssize_t;  /* byte count or error */
- #endif
-+
-+#define _SSIZE_T_DEFINED
-+#define _SSIZE_T_DEFINED_
-+#define __DEFINED_ssize_t
-+#define __ssize_t_defined
-+#define _SSIZE_T
-+#define _SSIZE_T_
-+
- #endif
- #ifndef MAX_PATH
--- 
-2.26.0
-
index 9bdc054909caeccf54b8e6347e00b43bc66989ca..42bfee945d82ea3fc4621c95ffb5d69f178fd23f 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_ASSIMP
        bool "assimp"
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_WCHAR
+       select BR2_PACKAGE_ZLIB
        help
          Open Asset Import Library (assimp) is a portable Open Source
          library to import various well-known 3D model formats in a
index e1b9a23499fd82b2a99748e62cd842ad8bb64af4..eddfbc48b04fc0858a7342db8378beb8a1a7a6e0 100644 (file)
@@ -8,6 +8,7 @@ ASSIMP_VERSION = 5.0.1
 ASSIMP_SITE = $(call github,assimp,assimp,v$(ASSIMP_VERSION))
 ASSIMP_LICENSE = BSD-3-Clause
 ASSIMP_LICENSE_FILES = LICENSE
+ASSIMP_DEPENDENCIES = zlib
 ASSIMP_INSTALL_STAGING = YES
 
 # relocation truncated to fit: R_68K_GOT16O. We also need to disable
@@ -36,7 +37,7 @@ ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
 ASSIMP_CXXFLAGS += -O0
 endif
 
-ASSIMP_CONF_OPTS += -DASSIMP_BUILD_ZLIB=ON -DASSIMP_BUILD_TESTS=OFF \
+ASSIMP_CONF_OPTS += -DASSIMP_BUILD_TESTS=OFF \
        -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) $(ASSIMP_CXXFLAGS)"
 
 $(eval $(cmake-package))