package/vlc: add optional support for musepack
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 28 Feb 2016 20:18:28 +0000 (21:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Mar 2016 14:02:37 +0000 (15:02 +0100)
When musepack was compiled before, vlc will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/vlc/plugins/demux/libmpc_plugin.so | grep NEEDED | sort
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libdl.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libintl.so.8]
 0x0000000000000001 (NEEDED)             Shared library: [libmpcdec.so.7]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/vlc.mk

index b67bd3555181bf496bfb08cc0de71a9402f989f9..46a7cad148e78bc4af60570cc320126b583c678a 100644 (file)
@@ -340,6 +340,13 @@ ifeq ($(BR2_PACKAGE_MINIZIP),y)
 VLC_DEPENDENCIES += minizip
 endif
 
+ifeq ($(BR2_PACKAGE_MUSEPACK),y)
+VLC_CONF_OPTS += --enable-mpc
+VLC_DEPENDENCIES += musepack
+else
+VLC_CONF_OPTS += --disable-mpc
+endif
+
 ifeq ($(BR2_PACKAGE_QT_GUI_MODULE),y)
 VLC_CONF_OPTS += --enable-qt
 VLC_CONF_ENV += \