package/mesa3d: select gbm if no glx, no egl and no osmesa-classic
authorRomain Naour <romain.naour@gmail.com>
Sat, 22 Feb 2020 16:01:01 +0000 (17:01 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 22 Feb 2020 18:34:48 +0000 (19:34 +0100)
This issue has been trigged since [1]:
"package/mesa3d: add option to configure gbm support"

Before the patch, the gbm support was autodetected by meson and enabled
only when at least one dri driver was enabled [2].

On the Buildroot side, the gbm support was explicitely enabled only when
BR2_PACKAGE_MESA3D_OPENGL_EGL was set.

Now, the gbm support is explicitely disabled but the meson build system
check if at least one option OpenGL GLX or OpenGL EGL or GBM or
OSMesa (classic) library is enabled [3].

The previous behavious was to enable GBM when GLX, EGL and OSMesa are
disabled. So select GBM symbol for this case.

Fixes:
http://autobuild.buildroot.net/results/a14f329560f8022f7ba8ec43ad8eed84e005d226

[1] b6c051acf787c804e732bc58ba8d7e440701a168
[2] https://gitlab.freedesktop.org/mesa/mesa/blob/19.3/meson.build#L348
[3] https://gitlab.freedesktop.org/mesa/mesa/blob/19.3/meson.build#L449

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/mesa3d/Config.in

index dbfc59bad599e084c763e091c9aaac799ad5db4d..a7d516e103c11d6dba12fd41d5b0addb0f41762a 100644 (file)
@@ -61,6 +61,10 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER
 config BR2_PACKAGE_MESA3D_DRI_DRIVER
        bool
        select BR2_PACKAGE_MESA3D_DRIVER
+       select BR2_PACKAGE_MESA3D_GBM if \
+               !BR2_PACKAGE_MESA3D_OPENGL_GLX && \
+               !BR2_PACKAGE_MESA3D_OPENGL_EGL && \
+               !BR2_PACKAGE_MESA3D_OSMESA_CLASSIC
        select BR2_PACKAGE_XLIB_LIBXSHMFENCE if \
                (BR2_PACKAGE_XORG7 && BR2_TOOLCHAIN_HAS_SYNC_4)