package/zxing-cpp: replace ZXING_CPP_MAKE_OPTS workaround
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 9 Jan 2020 22:39:14 +0000 (23:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 10 Jan 2020 21:32:38 +0000 (22:32 +0100)
Bumping to version e0e40dd in commit
ad9c5bbfa7ee355b9f6120358cde08ae866537ac included the following upstream
commit:
https://github.com/glassechidna/zxing-cpp/commit/4e2b4fe1668c60d73e7649b0d3d5888912878392

This commit contains CMake improvements and especially a new
BUILD_TESTING option that disable the testrunner compile, use this
instead of the ZXING_CPP_MAKE_OPTS workaround.

Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/zxing-cpp/zxing-cpp.mk

index 1efd986c7da022c93487029d0d05f33916ffb953..6b26c20e0084ee6c1491b46a4e8db84024568ee6 100644 (file)
@@ -10,12 +10,10 @@ ZXING_CPP_LICENSE = Apache-2.0
 ZXING_CPP_LICENSE_FILES = COPYING
 ZXING_CPP_INSTALL_STAGING = YES
 ZXING_CPP_SUPPORTS_IN_SOURCE_BUILD = NO
+ZXING_CPP_CONF_OPTS = -DBUILD_TESTING=OFF
 
 ifeq ($(BR2_PACKAGE_LIBICONV),y)
 ZXING_CPP_DEPENDENCIES += libiconv
 endif
 
-# build all targets except testrunner (needs c++11 support)
-ZXING_CPP_MAKE_OPTS = libzxing zxing
-
 $(eval $(cmake-package))