package/tpm2-pkcs11: add p11-kit optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 7 Feb 2021 09:19:29 +0000 (10:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 7 Feb 2021 09:55:09 +0000 (10:55 +0100)
Fixes:
 - http://autobuild.buildroot.org/results/fee607da7226a92cceab2bbfd4c5d031016dfa3d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tpm2-pkcs11/tpm2-pkcs11.mk

index fb3846f05622e079deba3cf675ed254a1fd5c156..3acce07745fb508dc604507583eed24b62f46098 100644 (file)
@@ -37,4 +37,10 @@ TPM2_PKCS11_CONF_ENV += \
        ac_cv_prog_tpm2_import=yes \
        ac_cv_prog_tpm2_changeauth=yes
 
+ifeq ($(BR2_PACKAGE_P11_KIT),y)
+TPM2_PKCS11_DEPENDENCIES += p11-kit
+TPM2_PKCS11_CONF_OPTS += \
+       --with-p11kitconfigdir=/usr/share/p11-kit/modules
+endif
+
 $(eval $(autotools-package))