hostapd: add support for Realtek driver
authorAlexander Mukhin <alexander.i.mukhin@gmail.com>
Thu, 14 Sep 2017 11:08:11 +0000 (14:08 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 24 Nov 2017 20:45:17 +0000 (21:45 +0100)
Since kernel drivers for Realtek wireless chips use non-standard
interfaces, upstream hostapd does not support them. One have to apply
an external patch for hostapd to work with these chips. See:
https://github.com/pritambaral/hostapd-rtl871xdrv

A configuration option is added to enable support for Realtek chips,
and it's turned off by default.

Signed-off-by: Alexander Mukhin <alexander.i.mukhin@gmail.com>
Tested-by: Angelo Compagnucci <angelo.compagnucci@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/hostapd/Config.in
package/hostapd/hostapd.hash
package/hostapd/hostapd.mk

index e4aeae6aaf63c2d85a6f23a6064de8e8aa315075..8a44e042efa4927da8f78ddb860d17fd4dcb9d89 100644 (file)
@@ -78,6 +78,9 @@ F:    package/putty/
 N:     Alexander Lukichev <alexander.lukichev@espotel.com>
 F:     package/openpgm/
 
+N:     Alexander Mukhin <alexander.i.mukhin@gmail.com>
+F:     package/hostapd/
+
 N:     Alexander Varnin <fenixk19@mail.ru>
 F:     package/liblog4c-localtime/
 
index 1609d0df5db5220eb0ff05747f3761c5c9a8f8b0..40c7015e73c67f6a9ad4baf6a3e1ef7afc9c687a 100644 (file)
@@ -14,6 +14,11 @@ config BR2_PACKAGE_HOSTAPD
 
 if BR2_PACKAGE_HOSTAPD
 
+config BR2_PACKAGE_HOSTAPD_DRIVER_RTW
+       bool "Enable rtl871xdrv driver"
+       help
+         Enable support for Realtek wireless chips.
+
 config BR2_PACKAGE_HOSTAPD_ACS
        bool "Enable ACS"
        default y
index b20c89b18485d8a57ee2590146482d1791b35452..588879f65a12dd8f5a222a5af4425d968965ac79 100644 (file)
@@ -1,4 +1,5 @@
 # Locally calculated
 sha256  01526b90c1d23bec4b0f052039cc4456c2fd19347b4d830d1d58a0a6aea7117d  hostapd-2.6.tar.gz
+sha256  e204da659d0583c71af23cb9b55536fe99598ee26a44104344f456e4d17350c6  rtlxdrv.patch
 sha256  529113cc81256c6178f3c1cf25dd8d3f33e6d770e4a180bd31c6ab7e4917f40b  rebased-v2.6-0001-hostapd-Avoid-key-reinstallation-in-FT-handshake.patch
 sha256  147c8abe07606905d16404fb2d2c8849796ca7c85ed8673c09bb50038bcdeb9e  rebased-v2.6-0005-Fix-PTK-rekeying-to-generate-a-new-ANonce.patch
index 3f94c8c4b758de55d99d3941819cf7d6a4dc51b3..bb3919e9888c060e9537e8be0c542bba58777291 100644 (file)
@@ -47,6 +47,11 @@ HOSTAPD_CONFIG_DISABLE += CONFIG_EAP_PWD
 HOSTAPD_CONFIG_EDITS += 's/\#\(CONFIG_TLS=\).*/\1internal/'
 endif
 
+ifeq ($(BR2_PACKAGE_HOSTAPD_DRIVER_RTW),y)
+HOSTAPD_PATCH = https://github.com/pritambaral/hostapd-rtl871xdrv/raw/master/rtlxdrv.patch
+HOSTAPD_CONFIG_SET += CONFIG_DRIVER_RTW
+endif
+
 ifeq ($(BR2_PACKAGE_HOSTAPD_ACS),y)
 HOSTAPD_CONFIG_ENABLE += CONFIG_ACS
 endif