package/open62541: cleanup tools files after installation
authorScott Fan <fancp2007@gmail.com>
Mon, 22 Feb 2021 05:39:52 +0000 (13:39 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 25 Jul 2021 21:57:58 +0000 (23:57 +0200)
The open62541 tools directory is indeed 52 MiB, which built as a standalone package
named 'libopen62541-1-tools' in launchpad. Nothing is required at runtime.

See the official debian control file template:
https://raw.githubusercontent.com/open62541/open62541/master/debian/control-template

See https://launchpad.net/~open62541-team/+archive/ubuntu/ppa/+packages
libopen62541-1       Open source implementation of OPC UA - shared library
libopen62541-1-dev   Open source implementation of OPC UA - development files
libopen62541-1-tools Open source implementation of OPC UA - tools
open62541-doc        Open source implementation of OPC UA - documentation

Signed-off-by: Scott Fan <fancp2007@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/open62541/open62541.mk

index 102e09a4297d4806d18d55f6f8c4d9a158c5b4df..3f751968179844fc82153ed790c17f8e853836b0 100644 (file)
@@ -54,4 +54,11 @@ else
 OPEN62541_CONF_OPTS += -DUA_ENABLE_PUBSUB_INFORMATIONMODEL=OFF
 endif
 
+# Remove unneeded files
+define OPEN62541_REMOVE_UNNEEDED_FILES
+       $(RM) -r $(TARGET_DIR)/usr/share/open62541
+endef
+
+OPEN62541_POST_INSTALL_TARGET_HOOKS += OPEN62541_REMOVE_UNNEEDED_FILES
+
 $(eval $(cmake-package))