package/bluez5_utils: enable support for external ell
authorJörg Krause <joerg.krause@embedded.rocks>
Mon, 16 Mar 2020 16:52:53 +0000 (17:52 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 21 Mar 2020 16:01:17 +0000 (17:01 +0100)
Bluez5' support for the mesh profile needs ell, the Embedded Linux
Library, at least version 0.28.

Although Bluez5 bundles an internal copy of ell version 0.28, we prefer
building with external libraries.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bluez5_utils/Config.in
package/bluez5_utils/bluez5_utils.mk

index 038c6e7095a19055d25c119cb7057b6d0f706b81..1e9eda31dcc6c66c7ddfe0508a55c8458699a302 100644 (file)
@@ -62,6 +62,7 @@ config BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_HEALTH
 
 config BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_MESH
        bool "build mesh profile"
+       select BR2_PACKAGE_ELL
        select BR2_PACKAGE_JSON_C
        select BR2_PACKAGE_READLINE
        help
index 2d95899f44d1032251d101813b99beb06bbae3cc..2149614c56f5192f2dadba6792c3fd177e4d7436 100644 (file)
@@ -53,10 +53,10 @@ endif
 
 # enable mesh profile
 ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS_PLUGINS_MESH),y)
-BLUEZ5_UTILS_CONF_OPTS += --enable-mesh
-BLUEZ5_UTILS_DEPENDENCIES += json-c readline
+BLUEZ5_UTILS_CONF_OPTS += --enable-external-ell --enable-mesh
+BLUEZ5_UTILS_DEPENDENCIES += ell json-c readline
 else
-BLUEZ5_UTILS_CONF_OPTS += --disable-mesh
+BLUEZ5_UTILS_CONF_OPTS += --disable-external-ell --disable-mesh
 endif
 
 # enable midi profile