package: s/$(STRIP)/$(STRIPCMD)/
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 25 Apr 2008 13:43:00 +0000 (13:43 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 25 Apr 2008 13:43:00 +0000 (13:43 -0000)
package/dummy/dummy.mk
package/oprofile/oprofile.mk
package/qtopia4/qtopia4.mk
package/webif/webif.mk

index 640af12436955484c5e71728f81b7734ee7b5049..f4b5590a3bf37665674f66fbb7ee9f78e84adf84 100644 (file)
@@ -60,7 +60,7 @@ $(DUMMY_DIR)/$(DUMMY_BINARY): $(DUMMY_DIR)/.configured
 # target root directory, to not waste valuable flash space.
 $(TARGET_DIR)/$(DUMMY_TARGET_BINARY): $(DUMMY_DIR)/$(DUMMY_BINARY)
        cp -dpf $(DUMMY_DIR)/dummy $@
-       $(STRIP) --strip-unneeded $@
+       $(STRIPCMD) --strip-unneeded $@
 
 # Main rule which shows which other packages must be installed before the dummy
 # package is installed. This to ensure that all depending libraries are
index a0faf85e4a5df40b6a9bd900b0d26efa729a90e2..a82d6ab7c7ad1d5f1335290347791ed6a91ed877 100644 (file)
@@ -50,7 +50,7 @@ $(TARGET_DIR)/usr/bin/oprofiled: $(OPROFILE_DIR)/daemon/oprofiled
        $(INSTALL) -m 644 $(OPROFILE_DIR)/libregex/stl.pat $(TARGET_DIR)/usr/share/oprofile
        $(INSTALL) -m 755 $(OPROFILE_DIR)/utils/opcontrol $(TARGET_DIR)/usr/bin
        $(INSTALL) -m 755 $(addprefix $(OPROFILE_DIR)/, $(OPROFILE_BINARIES)) $(TARGET_DIR)/usr/bin
-       $(STRIP) --strip-unneeded $(addprefix $(TARGET_DIR)/usr/bin/, $(notdir $(OPROFILE_BINARIES)))
+       $(STRIPCMD) --strip-unneeded $(addprefix $(TARGET_DIR)/usr/bin/, $(notdir $(OPROFILE_BINARIES)))
        touch -c $@
 
 oprofile: uclibc popt binutils_target $(TARGET_DIR)/usr/bin/oprofiled
index a66b8925b4957d5db6082728d53d3b0e7ca53bd2..acbf86a372c477ded8395dbbaae712ec532bd882 100644 (file)
@@ -260,13 +260,13 @@ $(TARGET_DIR)/usr/lib/libQtCore.so.4: $(STAGING_DIR)/usr/lib/libQtCore.la
        cp -dpf $(STAGING_DIR)/usr/lib/fonts/micro*.qpf $(TARGET_DIR)/usr/lib/fonts
 ifeq ($(BR2_PACKAGE_QTOPIA4_SHARED),y)
        cp -dpf $(STAGING_DIR)/usr/lib/libQt*.so.* $(TARGET_DIR)/usr/lib/
-       -$(STRIP) --strip-unneeded $(TARGET_DIR)/usr/lib/libQt*.so.*
+       -$(STRIPCMD) --strip-unneeded $(TARGET_DIR)/usr/lib/libQt*.so.*
 endif
        # Install image plugins if they are built
        if [ -d $(STAGING_DIR)/usr/plugins/imageformats ]; then \
                mkdir -p $(TARGET_DIR)/usr/plugins; \
                cp -dpfr $(STAGING_DIR)/usr/plugins/imageformats $(TARGET_DIR)/usr/plugins/; \
-               $(STRIP) --strip-unneeded $(TARGET_DIR)/usr/plugins/imageformats/*; \
+               $(STRIPCMD) --strip-unneeded $(TARGET_DIR)/usr/plugins/imageformats/*; \
        fi
 ifneq ($(BR2_PACKAGE_QTOPIA4_SQL),y)
        # Remove Sql libraries, not needed
index 32dd3b360e564f6db9035feab6719c85e6c33130..e3dd8fa6e691a75459b5e620c0f0afa7b235d6ba 100644 (file)
@@ -15,7 +15,7 @@ $(WEBIF_DIR)/.unpacked:
 $(WEBIF_DIR)/.built: $(WEBIF_DIR)/.unpacked
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(WEBIF_DIR)/webif-page $(WEBIF_SOURCE)/src/webif-page.c
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(WEBIF_DIR)/bstrip $(WEBIF_SOURCE)/src/bstrip.c
-       $(STRIP) --strip-unneeded $(WEBIF_DIR)/webif-page $(WEBIF_DIR)/bstrip
+       $(STRIPCMD) --strip-unneeded $(WEBIF_DIR)/webif-page $(WEBIF_DIR)/bstrip
        touch $@
 
 $(TARGET_DIR)/www/webif.css: $(WEBIF_DIR)/.built