package/kodi: remove AMLogic support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 10 Aug 2019 10:59:52 +0000 (12:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 11 Aug 2019 12:23:05 +0000 (14:23 +0200)
Kodi 19 will remove specific support for AMLogic:
https://github.com/xbmc/xbmc/pull/16043

Also buildroot dropped support for the odroid2c defconfig:
https://git.buildroot.net/buildroot/commit/?id=b80712a16ae3deb65331a7923aa878e13e2e66b6

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/kodi/Config.in
package/kodi/kodi.mk

index de05b07c97a90d2e9cb53c0a600ad98b48a98d0d..03d17d1743aaea9620cd8ab7dd89dfe08d210c8d 100644 (file)
@@ -146,6 +146,13 @@ endif
 
 comment "Legacy options removed in 2019.08"
 
+config BR2_PACKAGE_KODI_PLATFORM_AML
+       bool "Kodi AMLogic support was removed"
+       select BR2_LEGACY
+       help
+         Support for AMLogic was removed due to the removal of the
+         odroidc2 defconfig.
+
 config BR2_GCC_VERSION_6_X
        bool "gcc 6.x support removed"
        select BR2_LEGACY
index 279b4ead0d7ece304cd74a00ababc13122582cea..626038e8c8c6606b88b6c36c4d90ae4bdb65657f 100644 (file)
@@ -18,13 +18,6 @@ comment "kodi needs python w/ .py modules, a uClibc or glibc toolchain w/ C++, t
 config BR2_PACKAGE_KODI_PLATFORM_SUPPORTS
        bool
 
-config BR2_PACKAGE_KODI_PLATFORM_SUPPORTS_AML
-       bool
-       default y
-       depends on BR2_PACKAGE_LIBAMCODEC
-       depends on BR2_PACKAGE_ODROID_MALI
-       select BR2_PACKAGE_KODI_PLATFORM_SUPPORTS
-
 config BR2_PACKAGE_KODI_PLATFORM_SUPPORTS_RBPI
        bool
        default y
@@ -202,10 +195,6 @@ choice
        prompt "platform"
        default BR2_PACKAGE_KODI_PLATFORM_X11_OPENGL
 
-config BR2_PACKAGE_KODI_PLATFORM_AML
-       bool "AMLogic"
-       depends on BR2_PACKAGE_KODI_PLATFORM_SUPPORTS_AML
-
 config BR2_PACKAGE_KODI_PLATFORM_RBPI
        bool "Raspberry Pi"
        depends on BR2_PACKAGE_KODI_PLATFORM_SUPPORTS_RBPI
index 590af15b7c9da252367b981203b5c2798c2f6e70..6e482e615c90f4802124cb08d5ff11317153e398 100644 (file)
@@ -163,16 +163,6 @@ ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 KODI_CXX_FLAGS += -latomic
 endif
 
-ifeq ($(BR2_PACKAGE_KODI_PLATFORM_AML),y)
-KODI_CONF_OPTS += -DENABLE_AML=ON -DENABLE_OPENGLES=ON
-# The following line can be removed when bumping to 18.0-Leia,
-# see upstream PR 13425
-KODI_CXX_FLAGS += -DMESA_EGL_NO_X11_HEADERS
-KODI_DEPENDENCIES += libamcodec odroid-mali
-else
-KODI_CONF_OPTS += -DENABLE_AML=OFF
-endif
-
 ifeq ($(BR2_PACKAGE_KODI_PLATFORM_RBPI),y)
 KODI_CONF_OPTS += -DCORE_SYSTEM_NAME=rbpi -DENABLE_OPENGLES=ON
 KODI_DEPENDENCIES += rpi-userland