gst-plugins-bad: make more dependency-less plugins configurable
authorSven Neumann <s.neumann@raumfeld.com>
Thu, 3 Dec 2009 22:34:18 +0000 (23:34 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 8 Dec 2009 13:51:53 +0000 (14:51 +0100)
The latest update added a few new plugins that were missing from
the buildroot configuration system. This commit makes these
dependency-less plugins configurable.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/multimedia/gst-plugins-bad/Config.in
package/multimedia/gst-plugins-bad/gst-plugins-bad.mk

diff --git a/CHANGES b/CHANGES
index 45697f3c36dbf97c26afe05ffaf7806ac833a1ed..816b26d4ea9a62d262de48f1b97d29337a761b74 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -3,8 +3,8 @@
        New packages: tcpreplay, hostapd
 
        Updated/fixed packages: autoconf, bind, binutils, busybox,
-       directfb, iw, libfuse, libpcap, lighttpd, mesa, pcre, sshfs,
-       usbutils
+       directfb, gst-plugins-bad, iw, libfuse, libpcap, lighttpd,
+       mesa, pcre, sshfs, usbutils
 
        Issues resolved (http://bugs.uclibc.org):
 
index 8601cf45a83cde94d367c08ce6765aea17070fc5..c7ebe2a611da6915de2c14401435c16bdfacd22a 100644 (file)
@@ -21,6 +21,9 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AIFFPARSE
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AMRPARSE
        bool "amrparse"
 
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ASFMUX
+       bool "asfmux"
+
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUTOCONVERT
        bool "autoconvert"
 
@@ -54,9 +57,15 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FESTIVAL
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREEZE
        bool "freeze"
 
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREI0R
+       bool "frei0r"
+
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_H264PARSE
        bool "h264parse"
 
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_HDVPARSE
+       bool "hdvparse"
+
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIBRFB
        bool "librfb"
 
@@ -114,6 +123,9 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDP
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SELECTOR
        bool "selector"
 
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SHAPEWIPE
+       bool "shapewipe"
+
 config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SIREN
        bool "siren"
 
index c6c5fd0b780001d2fe3d79d18512864ebba16e2f..9a0955fd4220767e1562780a2076e510eb730cbe 100644 (file)
@@ -33,6 +33,12 @@ else
 GST_PLUGINS_BAD_CONF_OPT += --disable-amrparse
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ASFMUX),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-asfmux
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-asfmux
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUTOCONVERT),y)
 GST_PLUGINS_BAD_CONF_OPT += --enable-autoconvert
 else
@@ -99,12 +105,24 @@ else
 GST_PLUGINS_BAD_CONF_OPT += --disable-freeze
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREI0R),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-frei0r
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-frei0r
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_H264PARSE),y)
 GST_PLUGINS_BAD_CONF_OPT += --enable-h264parse
 else
 GST_PLUGINS_BAD_CONF_OPT += --disable-h264parse
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_HDVPARSE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-hdvparse
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-hdvparse
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIBRFB),y)
 GST_PLUGINS_BAD_CONF_OPT += --enable-librfb
 else
@@ -219,6 +237,12 @@ else
 GST_PLUGINS_BAD_CONF_OPT += --disable-selector
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SHAPEWIPE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-shapewipe
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-shapewipe
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SIREN),y)
 GST_PLUGINS_BAD_CONF_OPT += --enable-siren
 else