mtd: install header files to staging directory
authorJörg Krause <joerg.krause@embedded.rocks>
Fri, 29 Apr 2016 07:56:58 +0000 (09:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 May 2016 20:36:29 +0000 (22:36 +0200)
These header files are required by swupdate.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mtd/mtd.mk

index adbf28d8f6d7acb720368ebd90d3327deff9255b..bf90212f5c8ab6066549037b2d518345df097761 100644 (file)
@@ -107,6 +107,9 @@ endef
 define MTD_INSTALL_STAGING_CMDS
        $(INSTALL) -D -m 0755 $(@D)/lib/libmtd.a $(STAGING_DIR)/usr/lib/libmtd.a
        $(INSTALL) -D -m 0755 $(@D)/ubi-utils/libubi.a $(STAGING_DIR)/usr/lib/libubi.a
+       $(INSTALL) -D -m 0644 $(@D)/include/libmtd.h $(STAGING_DIR)/usr/include/mtd/libmtd.h
+       $(INSTALL) -D -m 0644 $(@D)/ubi-utils/include/libubi.h $(STAGING_DIR)/usr/include/mtd/libubi.h
+       $(INSTALL) -D -m 0644 $(@D)/include/mtd/ubi-media.h $(STAGING_DIR)/usr/include/mtd/ubi-media.h
 endef
 
 define MTD_INSTALL_TARGET_CMDS