- Add a system-V init script to ntpd. Closes #518
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 25 Jun 2007 18:27:58 +0000 (18:27 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 25 Jun 2007 18:27:58 +0000 (18:27 -0000)
package/ntp/ntp.mk
package/ntp/ntp.sysvinit [new file with mode: 0755]

index f09703cf2cd3e3fcce0e608cb54c87cd8f1488ff..1bff81909eb5753c5735858dadecdad7a9a8bf47 100644 (file)
@@ -57,6 +57,7 @@ $(NTP_DIR)/$(NTP_BINARY): $(NTP_DIR)/.configured
 $(TARGET_DIR)/$(NTP_TARGET_BINARY): $(NTP_DIR)/$(NTP_BINARY)
        install -m 755 $(NTP_DIR)/ntpd/ntpd $(TARGET_DIR)/usr/sbin/ntpd
        install -m 755 $(NTP_DIR)/$(NTP_BINARY) $(TARGET_DIR)/$(NTP_TARGET_BINARY)
+       install -m 755 package/ntp/ntp.sysvinit $(TARGET_DIR)/etc/init.d/S49ntp
 
 ntp: uclibc $(TARGET_DIR)/$(NTP_TARGET_BINARY)
 
diff --git a/package/ntp/ntp.sysvinit b/package/ntp/ntp.sysvinit
new file mode 100755 (executable)
index 0000000..4e8f110
--- /dev/null
@@ -0,0 +1,46 @@
+#! /bin/sh
+#
+# System-V init script for the openntp daemon
+#
+
+set -e
+
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+DESC="network time protocol daemon"
+NAME=ntpd
+DAEMON=/usr/sbin/$NAME
+
+# Gracefully exit if the package has been removed.
+test -x $DAEMON || exit 0
+
+# Read config file if it is present.
+if [ -r /etc/default/$NAME ]
+then
+       . /etc/default/$NAME
+fi
+
+case "$1" in
+  start) echo -n "Starting $DESC: $NAME"
+       start-stop-daemon -S -q -x $DAEMON
+       echo "."
+       ;;
+  stop) echo -n "Stopping $DESC: $NAME"
+       start-stop-daemon -K -q -n $NAME
+       echo "."
+       ;;
+  reload|force-reload) echo -n "Reloading $DESC configuration..."
+       start-stop-daemon -K -q -n $NAME -s 1
+       echo "done."
+  ;;
+  restart) echo -n "Restarting $DESC: $NAME"
+       start-stop-daemon -K -q -n $NAME
+       sleep 1
+       start-stop-daemon -S -q -x $DAEMON
+       echo "."
+       ;;
+  *) echo "Usage: $SCRIPTNAME {start|stop|restart|reload|force-reload}" >&2
+       exit 1
+       ;;
+esac
+
+exit 0