package/minizip: fix build without openssl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 25 Dec 2020 22:13:43 +0000 (23:13 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 25 Dec 2020 22:49:03 +0000 (23:49 +0100)
Disable PKWARE traditional and WinZIP AES encryption without openssl to
avoid the following build failure due to MZ_FETCH_LIBS being set to OFF
since commit f9d31de3b7585e3521aafe2089fcff79bf7f037d

Fixes:
 - http://autobuild.buildroot.org/results/ae16497bf56df9ce4be97651b5ce65f75bdf909f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/minizip/minizip.mk

index e2abfd4f2028c46ed6ee9c8b3a8a0a0676c33691..9e60bc2aabe104798faea2391aab19b03a63ea16 100644 (file)
@@ -38,9 +38,15 @@ endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 MINIZIP_DEPENDENCIES += openssl
-MINIZIP_CONF_OPTS += -DMZ_OPENSSL=ON
+MINIZIP_CONF_OPTS += \
+       -DMZ_OPENSSL=ON \
+       -DMZ_PKCRYPT=ON \
+       -DMZ_WZAES=ON
 else
-MINIZIP_CONF_OPTS += -DMZ_OPENSSL=OFF
+MINIZIP_CONF_OPTS += \
+       -DMZ_OPENSSL=OFF \
+       -DMZ_PKCRYPT=OFF \
+       -DMZ_WZAES=OFF
 endif
 
 ifeq ($(BR2_PACKAGE_XZ),y)