package/libuev: new package
authorPeter Seiderer <ps.report@gmx.net>
Mon, 20 Jul 2020 20:48:24 +0000 (22:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 16 Aug 2020 20:21:11 +0000 (22:21 +0200)
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/libuev/Config.in [new file with mode: 0644]
package/libuev/libuev.hash [new file with mode: 0644]
package/libuev/libuev.mk [new file with mode: 0644]

index 9a161c80367db959bf6553d0c3d80f8b02db0ba0..516e2598319ccfd9715c7e5b362c1fd71cef28d4 100644 (file)
@@ -2054,6 +2054,7 @@ F:        package/gstreamer1/gst1-validate/
 F:     package/gstreamer1/gstreamer1-editing-services/
 F:     package/iwd/
 F:     package/libevdev/
+F:     package/libuev/
 F:     package/log4cplus/
 F:     package/postgresql/
 F:     package/python-colorzero/
index f1229837246c4b6cc954e04a8a8c0e6ce3114c5f..6bd2699354909363083ac60d0a2a379caa8de63d 100644 (file)
@@ -1738,6 +1738,7 @@ menu "Networking"
        source "package/libtirpc/Config.in"
        source "package/libtorrent/Config.in"
        source "package/libtorrent-rasterbar/Config.in"
+       source "package/libuev/Config.in"
        source "package/libuhttpd/Config.in"
        source "package/libupnp/Config.in"
        source "package/libupnp18/Config.in"
diff --git a/package/libuev/Config.in b/package/libuev/Config.in
new file mode 100644 (file)
index 0000000..bb50099
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBUEV
+       bool "libuev"
+       help
+         Simple event loop for Linux.
+
+         https://github.com/troglobit/libuev
diff --git a/package/libuev/libuev.hash b/package/libuev/libuev.hash
new file mode 100644 (file)
index 0000000..fece0e9
--- /dev/null
@@ -0,0 +1,4 @@
+# From https://github.com/troglobit/libuev/releases/download/v2.3.1/libuev-2.3.1.tar.xz.md5
+md5  ec601f69f69477858fa023a75da23793  libuev-2.3.1.tar.xz
+# License files
+sha256  3c2bf3fdd85687242ba6f2b02b6ce5176aba15b5e1a2ccb8b608439197ec4641  LICENSE
diff --git a/package/libuev/libuev.mk b/package/libuev/libuev.mk
new file mode 100644 (file)
index 0000000..c7b73b4
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libuev
+#
+################################################################################
+
+LIBUEV_VERSION = 2.3.1
+LIBUEV_SOURCE = libuev-$(LIBUEV_VERSION).tar.xz
+LIBUEV_SITE = https://github.com/troglobit/libuev/releases/download/v$(LIBUEV_VERSION)
+LIBUEV_LICENSE = MIT
+LIBUEV_LICENSE_FILES = LICENSE
+LIBUEV_INSTALL_STAGING = YES
+LIBUEV_CONF_OPTS = --disable-examples
+
+$(eval $(autotools-package))