audit: disable python3 support
authorRyan Barnett <ryan.barnett@rockwellcollins.com>
Wed, 22 Jul 2015 21:06:40 +0000 (16:06 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Jul 2015 21:21:32 +0000 (23:21 +0200)
With the version bump to 2.4.3, python3 support was added for
libaudit. With host machines that have python3 installed, this will
cause build issues such as:

  make[5]: Entering directory `/tmp/ryan/buildroot/output/build/audit-2.4.3/bindings/swig/python3'
  swig -o audit_wrap.c -python -py3 -modern -I. -I../../.. -I../../../lib -I/usr/include/python3.4m -I/usr/include/python3.4m ./../src/auditswig.i
  make[5]: swig: Command not found

Solution is to disable python3 support such as we do with python2.7.

Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/audit/audit.mk

index 806bd971e537e02ef0b4f2bacf74d523de64caa7..61e876bb9e10c794a37200249906f7f588426642 100644 (file)
@@ -14,7 +14,7 @@ AUDIT_INSTALL_STAGING = YES
 # Patching Makefile.am
 AUDIT_AUTORECONF = YES
 
-AUDIT_CONF_OPTS = --without-python --disable-zos-remote
+AUDIT_CONF_OPTS = --without-python --without-python3 --disable-zos-remote
 
 ifeq ($(BR2_PACKAGE_LIBCAP_NG),y)
 AUDIT_DEPENDENCIES += libcap-ng