package/qemu: disable vhost-user with uclibc-ng
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 6 Aug 2021 21:10:48 +0000 (23:10 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 7 Aug 2021 08:21:28 +0000 (10:21 +0200)
Disable vhost-user on uclibc-ng as it raises build failures since bump
to version 6.0.0 in commit 6b86c9335fc3ff381878156c6243454d4b688df9 and
https://github.com/qemu/qemu/commit/810033be083040591fee2fc09f2f294670ed1930

The issue is that F_ADD_SEALS and F_SEAL_xxx variables are not defined on
uclibc-ng (even if MFD_ALLOW_SEALING is defined) resulting in the
following build failure:

../subprojects/libvhost-user/libvhost-user.c:1637:22: error: 'F_ADD_SEALS' undeclared (first use in this function)
 1637 |     ret = fcntl(*fd, F_ADD_SEALS, flags);
      |                      ^~~~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/9f393539931b51191cf7128e5c618c2398fc86c1

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: use conditional block like for all other OPTS]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/qemu/qemu.mk

index 470c285f168889832c4a4b216030748a1e4c1654..50ace104ceeeda098c03a822544170b5818cbd18 100644 (file)
@@ -56,6 +56,12 @@ endif
 
 endif
 
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+QEMU_OPTS += --disable-vhost-user
+else
+QEMU_OPTS += --enable-vhost-user
+endif
+
 ifeq ($(BR2_PACKAGE_QEMU_SLIRP),y)
 QEMU_OPTS += --enable-slirp=system
 QEMU_DEPENDENCIES += slirp