bind: fix build with openssl
authorBaruch Siach <baruch@tkos.co.il>
Wed, 18 Jul 2018 18:53:03 +0000 (21:53 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 19 Jul 2018 07:04:45 +0000 (09:04 +0200)
The bind configure.in uses AC_TRY_RUN that is not compatible with cross
compile. Disable eddsa unconditionally since it requires a newer OpenSSL
version than we currently have. Enable aes; this is always supported in
current OpenSSL versions.

Fixes:
http://autobuild.buildroot.net/results/3ed/3edb1659954b00401b68ffc7e1c8b3c29581c0e4/
http://autobuild.buildroot.net/results/025/025e377b51b39ba34647636ad0d0661a3cb95572/
http://autobuild.buildroot.net/results/725/7250564e780e43e793ae6c8c526985e5519681f4/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bind/bind.mk

index c4429ef6cc7f27cefd94a58de2bb9508a5ba6c11..e71eddcd7f001c98a1b7cff3c72adcc5210a8758 100644 (file)
@@ -61,7 +61,9 @@ BIND_CONF_ENV += \
        ac_cv_func_EVP_sha512=yes
 BIND_CONF_OPTS += \
        --with-openssl=$(STAGING_DIR)/usr LIBS="-lz" \
-       --with-ecdsa=yes
+       --with-ecdsa=yes \
+       --with-eddsa=no \
+       --with-aes=yes
 # GOST cipher support requires openssl extra engines
 ifeq ($(BR2_PACKAGE_OPENSSL_ENGINES),y)
 BIND_CONF_OPTS += --with-gost=yes