python-pyasn: use the real upstream
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 18 Feb 2014 20:40:08 +0000 (21:40 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 19 Feb 2014 07:59:27 +0000 (08:59 +0100)
The https://code.google.com/p/pyasn/ project is not really the real
upstream for PyASN, and at least not the upstream for the PyASN
implementation recommended by the PySNMP developers.

Instead, the real upstream is
https://pypi.python.org/packages/source/p/pyasn1/, which has had much
more regular releases than the other PyASN implementation.

Therefore, we switch to using this implementation, as recommended by
the PySNMP developers on http://pysnmp.sourceforge.net/download.html.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python-pyasn/python-pyasn.mk

index b0072225b6c66dbf0ac485062d5e3ab39091a7a7..43fabe9cff517dd35df0b867c5e15ccc5ff33d95 100644 (file)
@@ -4,16 +4,10 @@
 #
 ################################################################################
 
-PYTHON_PYASN_VERSION = 1.2
-PYTHON_PYASN_SOURCE = PyASN-$(PYTHON_PYASN_VERSION).zip
-PYTHON_PYASN_SITE = https://pyasn.googlecode.com/files
+PYTHON_PYASN_VERSION = 0.17
+PYTHON_PYASN_SOURCE = pyasn1-$(PYTHON_PYASN_VERSION).tar.gz
+PYTHON_PYASN_SITE = https://pypi.python.org/packages/source/p/pyasn1/
 PYTHON_PYASN_LICENSE = LGPLv3+ (pyasn.cpp), GPLv2+ (libgds)
 PYTHON_PYASN_SETUP_TYPE = distutils
 
-define PYTHON_PYASN_EXTRACT_CMDS
-       unzip -d $(@D) $(DL_DIR)/$(PYTHON_PYASN_SOURCE)
-       mv $(@D)/PyASN-$(PYTHON_PYASN_VERSION)/* $(@D)
-       $(RM) -r $(@D)/PyASN-$(PYTHON_PYASN_VERSION)
-endef
-
 $(eval $(python-package))